aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/tasks
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-05-19 09:12:40 +0000
committerRichard Purdie <richard@openedhand.com>2008-05-19 09:12:40 +0000
commit816639fb2e5ca2042b720bb259a668280d00f792 (patch)
tree2b31227da2cf98472a11fa69bad786e55520f3df /meta/packages/tasks
parent33826e00376e5b9e042e82ce7cc7226af92848a5 (diff)
downloadopenembedded-core-contrib-816639fb2e5ca2042b720bb259a668280d00f792.tar.gz
task-poky: Split out tools tasks to a separate file
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4497 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/tasks')
-rw-r--r--meta/packages/tasks/task-poky-tools.bb57
-rw-r--r--meta/packages/tasks/task-poky.bb51
2 files changed, 59 insertions, 49 deletions
diff --git a/meta/packages/tasks/task-poky-tools.bb b/meta/packages/tasks/task-poky-tools.bb
new file mode 100644
index 0000000000..359538a77a
--- /dev/null
+++ b/meta/packages/tasks/task-poky-tools.bb
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Tools tasks for Poky"
+PR = "r0"
+
+PACKAGES = "\
+ task-poky-tools-debug \
+ task-poky-tools-debug-dbg \
+ task-poky-tools-debug-dev \
+ task-poky-tools-profile \
+ task-poky-tools-profile-dbg \
+ task-poky-tools-profile-dev \
+ task-poky-tools-testapps \
+ task-poky-tools-testapps-dbg \
+ task-poky-tools-testapps-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-poky-tools-debug = "\
+ gdb \
+ gdbserver \
+ strace"
+
+RDEPENDS_task-poky-tools-profile = "\
+ exmap-console \
+ exmap-server \
+ oprofile \
+ oprofileui-server \
+ powertop \
+ lttng-control \
+ lttng-viewer"
+
+RDEPENDS_task-poky-tools-profile_qemux86 += "valgrind"
+
+RRECOMMENDS_task-poky-tools-profile = "\
+ kernel-module-oprofile"
+
+RDEPENDS_task-poky-tools-testapps = "\
+ blktool \
+ tslib-calibrate \
+ tslib-tests \
+ lrzsz \
+ kexec-tools \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ owl-video-widget \
+ gst-meta-video \
+ gst-meta-audio \
+ xrestop \
+ xwininfo \
+ xprop \
+ xvideo-tests"
diff --git a/meta/packages/tasks/task-poky.bb b/meta/packages/tasks/task-poky.bb
index 8204b6383f..f2fa2b2b45 100644
--- a/meta/packages/tasks/task-poky.bb
+++ b/meta/packages/tasks/task-poky.bb
@@ -1,9 +1,9 @@
#
-# Copyright (C) 2007 OpenedHand Ltd.
+# Copyright (C) 2007-2008 OpenedHand Ltd.
#
DESCRIPTION = "Tasks for OpenedHand Poky"
-PR = "r25"
+PR = "r26"
PACKAGES = "\
task-poky-apps-console \
@@ -24,15 +24,6 @@ PACKAGES = "\
task-poky-x11-sato \
task-poky-x11-sato-dbg \
task-poky-x11-sato-dev \
- task-poky-tools-debug \
- task-poky-tools-debug-dbg \
- task-poky-tools-debug-dev \
- task-poky-tools-profile \
- task-poky-tools-profile-dbg \
- task-poky-tools-profile-dev \
- task-poky-tools-testapps \
- task-poky-tools-testapps-dbg \
- task-poky-tools-testapps-dev \
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -105,41 +96,3 @@ RDEPENDS_task-poky-x11-sato = "\
settings-daemon \
networkmanager-applet \
gtk-sato-engine"
-
-
-RDEPENDS_task-poky-tools-debug = "\
- gdb \
- gdbserver \
- strace"
-
-
-RDEPENDS_task-poky-tools-profile = "\
- exmap-console \
- exmap-server \
- oprofile \
- oprofileui-server \
- powertop \
- lttng-control \
- lttng-viewer"
-
-RDEPENDS_task-poky-tools-profile_qemux86 += "valgrind"
-
-RRECOMMENDS_task-poky-tools-profile = "\
- kernel-module-oprofile"
-
-
-RDEPENDS_task-poky-tools-testapps = "\
- blktool \
- tslib-calibrate \
- tslib-tests \
- lrzsz \
- kexec-tools \
- alsa-utils-amixer \
- alsa-utils-aplay \
- owl-video-widget \
- gst-meta-video \
- gst-meta-audio \
- xrestop \
- xwininfo \
- xprop \
- xvideo-tests"