aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/speex
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-20 13:12:41 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-20 13:12:41 +0000
commite790b1a394f2c1b64bda3c04db284a7bf2e309d9 (patch)
tree8416569c352164bcd11b67866ba6e7579153f2e1 /meta/packages/speex
parentfa334003652967769b9b47c3f172fe1079c278bf (diff)
downloadopenembedded-core-contrib-e790b1a394f2c1b64bda3c04db284a7bf2e309d9.tar.gz
speex: upgrade to 1.2beta3 and disable floating point usage
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4106 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/speex')
-rw-r--r--meta/packages/speex/speex_1.1.12+1.2beta3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/packages/speex/speex_1.1.12+1.2beta3.bb b/meta/packages/speex/speex_1.1.12+1.2beta3.bb
new file mode 100644
index 0000000000..f1445100b4
--- /dev/null
+++ b/meta/packages/speex/speex_1.1.12+1.2beta3.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Speex is an Open Source/Free Software patent-free audio compression format designed for speech."
+SECTION = "libs"
+LICENSE = "BSD"
+HOMEPAGE = "http://www.speex.org"
+DEPENDS = "libogg"
+
+SRC_URI = "http://downloads.us.xiph.org/releases/speex/speex-1.2beta3.tar.gz"
+S = "${WORKDIR}/${PN}-1.2beta3"
+
+PARALLEL_MAKE = ""
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --enable-fixed-point --with-ogg-libraries=${STAGING_LIBDIR} \
+ --disable-float-api --disable-vbr \
+ --with-ogg-includes=${STAGING_INCDIR} --disable-oggtest"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES += "${PN}-bin"
+FILES_${PN} = "${libdir}/libspeex.so.*"
+FILES_${PN}-dev += "${libdir}/libspeex.so.*"
+FILES_${PN}-bin = "${bindir}"