aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-wm
diff options
context:
space:
mode:
authorMatthew Allum <mallum@openedhand.com>2006-08-07 15:05:12 +0000
committerMatthew Allum <mallum@openedhand.com>2006-08-07 15:05:12 +0000
commitd24a63938a484132a2ae2d5943d7ac96fccfcf8e (patch)
tree4f99052b59501ec536c722c2d130d449d27ad7a2 /meta/packages/matchbox-wm
parent0c8c1405192bba2bbc93af8f4f927bd9495f99ec (diff)
downloadopenembedded-core-contrib-d24a63938a484132a2ae2d5943d7ac96fccfcf8e.tar.gz
Add mb-wm 1.1 bb
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@591 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-wm')
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_1.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/matchbox-wm/matchbox-wm_1.1.bb b/meta/packages/matchbox-wm/matchbox-wm_1.1.bb
new file mode 100644
index 0000000000..4af6b0a4e0
--- /dev/null
+++ b/meta/packages/matchbox-wm/matchbox-wm_1.1.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common"
+RDEPENDS = "matchbox-common"
+PR="r0"
+
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.1/matchbox-window-manager-${PV}.tar.gz \
+ file://kbdconfig"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig update-alternatives
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}
+