aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-panel-hacks
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/matchbox-panel-hacks
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadopenembedded-core-contrib-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-panel-hacks')
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop7
-rwxr-xr-xmeta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home2
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop7
-rwxr-xr-xmeta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh9
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.pngbin0 -> 1651 bytes
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb23
6 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop
new file mode 100644
index 0000000000..4e08dfd379
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Home
+Comment=Home
+Exec=mb-applet-home
+Type=PanelApp
+Icon=xrandr.png
+Categories=Panel;Utility;MB
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home
new file mode 100755
index 0000000000..72aa76f227
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home
@@ -0,0 +1,2 @@
+#!/bin/sh
+mb-applet-launcher -na -o -1 -l --title "Home" mbdesktop.png matchbox-remote -d
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
new file mode 100644
index 0000000000..512e3771e4
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Screen Rotator
+Comment=Panel based Rotation tool.
+Exec=mb-applet-launcher -na -l --title "Screen Rotator" /usr/share/pixmaps/xrandr.png xrandr-panelapp.sh
+Type=PanelApp
+Icon=xrandr.png
+Categories=Panel;Utility;MB
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
new file mode 100755
index 0000000000..d17c805ffc
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+if [ -n "$(xrandr | grep rotation | grep left)" ]
+then
+xrandr -o normal
+xmodmap /etc/X11/xmodmap-portrait
+else
+xrandr -o left
+xmodmap /etc/X11/xmodmap-left
+fi
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
new file mode 100644
index 0000000000..08cd476e8a
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
Binary files differ
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
new file mode 100644
index 0000000000..46b0acfe2e
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
+DEPENDS = "matchbox xmodmap"
+SRC_URI = "file://xrandr-panelapp.sh \
+ file://xrandr-panelapp.desktop \
+ file://mb-applet-home \
+ file://home-panelapp.desktop \
+ file://xrandr.png"
+SECTION = "x11/wm"
+PRIORITY = "optional"
+PR = "r6"
+LICENSE = "MIT"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
+ install -m 0755 ${WORKDIR}/mb-applet-home ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/home-panelapp.desktop ${D}${datadir}/applications/
+
+}