aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-06-18 01:09:42 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2010-07-19 11:59:51 -0400
commitf0af0ba94a9084aa40e1b592dc8e0acaddfaee8d (patch)
tree6243aeb38247a1ee8e812bcf75fd0096eecffdab /meta/packages/linux
parent15624d13d0ee432a2ff28168ba58674c54550af0 (diff)
downloadopenembedded-core-contrib-f0af0ba94a9084aa40e1b592dc8e0acaddfaee8d.tar.gz
kernel: create base recipe for Wind River Linux kernel building
This base recipe implements support for building a git based Wind River Linux kernel repository. There are several restrictions in this first import: - no patching (needs guilt) - missing Wind River features (config audit, etc) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/packages/linux')
-rw-r--r--meta/packages/linux/linux-wrs_git.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-wrs_git.bb b/meta/packages/linux/linux-wrs_git.bb
new file mode 100644
index 0000000000..a4bdcab5d7
--- /dev/null
+++ b/meta/packages/linux/linux-wrs_git.bb
@@ -0,0 +1,82 @@
+DESCRIPTION = "Wind River Kernel"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+# Set this to 'preempt_rt' in the local.conf if you want a real time kernel
+LINUX_KERNEL_TYPE ?= standard
+DEPENDS = "kern-tools-native"
+PV = "2.6.34+git${SRCPV}"
+
+# To use a staged, on-disk bare clone of a Wind River Kernel, use a
+# variant of the below
+# SRC_URI = "git://///path/to/kernel/default_kernel.git;fullclone=1"
+SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${WRMACHINE}-${LINUX_KERNEL_TYPE}"
+
+
+WRMACHINE = "${MACHINE}
+WRMACHINE_qemux86 = "common_pc"
+WRMACHINE_qemuppc = "qemu_ppc32"
+WRMACHINE_qemumips = "mti_malta32_be"
+WRMACHINE_qemuarm = "arm_versatile_926ejs"
+
+LINUX_VERSION=v2.6.34
+LINUX_VERSION_EXTENSION="-wr-${LINUX_KERNEL_TYPE}"
+PR = r1
+PV = "2.6.34+${PR}+git${SRCREV}"
+
+S = "${WORKDIR}/linux"
+B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"
+
+do_patch() {
+ echo "[INFO] Patching is currently not supported"
+}
+
+do_wrlinux_checkout() {
+ if [ -d ${WORKDIR}/.git/refs/remotes/origin ]; then
+ echo "Fixing up git directory for ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
+ rm -rf ${S}
+ mkdir ${S}
+ mv ${WORKDIR}/.git ${S}
+ mv ${S}/.git/refs/remotes/origin/* ${S}/.git/refs/heads
+ rmdir ${S}/.git/refs/remotes/origin
+ fi
+ cd ${S}
+ git checkout -f ${WRMACHINE}-${LINUX_KERNEL_TYPE}
+}
+
+addtask wrlinux_checkout before do_patch after do_unpack
+
+do_wrlinux_configme() {
+ echo "Doing wrlinux configme"
+ rm -rf ${B}
+ cd ${S}
+ configme
+ echo "# CONFIG_WRNOTE is not set" >> ${B}/.config
+ echo "# Global settings from linux recipe" >> ${B}/.config
+ echo "CONFIG_LOCALVERSION="\"${LINUX_VERSION_EXTENSION}\" >> ${B}/.config
+}
+
+do_wrlinux_configcheck() {
+ echo "[INFO] validating kernel configuration"
+ cd ${B}/..
+ kconf_check ${B}/.config ${B} ${S} ${B} ${LINUX_VERSION} ${WRMACHINE}-${LINUX_KERNEL_TYPE}
+}
+
+do_wrlinux_link_vmlinux() {
+ if [ -n "${KERNEL_IMAGETYPE_LINK}" ]; then
+ cd ${B}/arch/${ARCH}/boot
+ ln -sf ../../../${KERNEL_IMAGETYPE_LINK}
+ fi
+}
+
+do_wrlinux_configme[depends] = "kern-tools-native:do_populate_sysroot"
+addtask wrlinux_configme before do_configure after do_patch
+addtask wrlinux_link_vmlinux after do_compile before do_install
+
+# XXX
+#addtask wrlinux_configcheck after do_configure before do_compile
+
+inherit kernel
+
+# object files are in B, not S, so we need to override this
+do_deploy[dirs] = "${B}"