aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/linux
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-08-13 16:10:55 +0100
committerJoshua Lock <josh@linux.intel.com>2010-08-13 17:25:39 +0100
commitaeb73bdf2035faaa3a9fa889200a831b9217a40f (patch)
treed38e187d8bbe3363619a7060456bbb8b11329bdd /meta/packages/linux
parent1c4cc60e282ef153cbcbbe56bb739912a0e0ea0c (diff)
downloadopenembedded-core-contrib-aeb73bdf2035faaa3a9fa889200a831b9217a40f.tar.gz
linux-wrs: Fix qemux86-64
Use the fragment support provided by kern-tools in the linux-wrs recipe to add some extra modules required for qemux86-64 such as evdev and uvesafb. Add a patch to increase CONNECTOR_MAX_MESSAGE_SIZE as uvesafb was sending larger messages than the kernel would accept. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/linux')
-rw-r--r--meta/packages/linux/linux-wrs/connect-size.patch35
-rw-r--r--meta/packages/linux/linux-wrs/qemux86-64.cfg10
-rw-r--r--meta/packages/linux/linux-wrs_git.bb8
3 files changed, 51 insertions, 2 deletions
diff --git a/meta/packages/linux/linux-wrs/connect-size.patch b/meta/packages/linux/linux-wrs/connect-size.patch
new file mode 100644
index 0000000000..a78629c85c
--- /dev/null
+++ b/meta/packages/linux/linux-wrs/connect-size.patch
@@ -0,0 +1,35 @@
+Increase the connector message size to avoid message to long errors from
+uvesafb as per the below dmesg fragment:
+
+uvesafb: Bochs/Plex86 Developers, Bochs/Plex86 VBE Adapter, $Id$, OEM: Bochs/Plex86 VBE(C) 2003 http://savannah.nongnu.org/projects/vgabios/, VBE v2.0
+uvesafb: no monitor limits have been set, default refresh rate will be used
+uvesafb: scrolling: redraw
+uvesafb: framebuffer at 0xe0000000, mapped to 0xffffc90000080000, using 8192k, total 8192k
+fb0: VESA VGA frame buffer device
+uvesafb: message too long (57808), can't execute task
+uvesafb: VBE get state call failed (eax=0x4f04, err=-7)
+udev: starting version 158
+EXT3-fs (hda): using internal journal
+uvesafb: message too long (57808), can't execute task
+uvesafb: VBE get state call failed (eax=0x4f04, err=-7)
+uvesafb: message too long (57808), can't execute task
+uvesafb: VBE get state call failed (eax=0x4f04, err=-7)
+uvesafb: message too long (57808), can't execute task
+uvesafb: VBE get state call failed (eax=0x4f04, err=-7)
+
+JL 13/0/10
+
+Index: linux/include/linux/connector.h
+===================================================================
+--- linux.orig/include/linux/connector.h 2010-08-13 13:16:28.000000000 +0100
++++ linux/include/linux/connector.h 2010-08-13 13:18:29.507791929 +0100
+@@ -48,7 +48,8 @@
+ /*
+ * Maximum connector's message size.
+ */
+-#define CONNECTOR_MAX_MSG_SIZE 16384
++//#define CONNECTOR_MAX_MSG_SIZE 16384
++#define CONNECTOR_MAX_MSG_SIZE 65536
+
+ /*
+ * idx and val are unique identifiers which
diff --git a/meta/packages/linux/linux-wrs/qemux86-64.cfg b/meta/packages/linux/linux-wrs/qemux86-64.cfg
new file mode 100644
index 0000000000..df3fbe32d0
--- /dev/null
+++ b/meta/packages/linux/linux-wrs/qemux86-64.cfg
@@ -0,0 +1,10 @@
+CONFIG_AGP=y
+CONFIG_DRM=y
+CONFIG_FB=y
+CONFIG_FB_MODE_HELPERS=y
+CONFIG_CONNECTOR=y
+CONFIG_FB_UVESA=m
+CONFIG_INPUT_TABLET=y
+CONFIG_TABLET_USB_WACOM=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_E1000=y
diff --git a/meta/packages/linux/linux-wrs_git.bb b/meta/packages/linux/linux-wrs_git.bb
index 427c97b1b0..38718464de 100644
--- a/meta/packages/linux/linux-wrs_git.bb
+++ b/meta/packages/linux/linux-wrs_git.bb
@@ -13,6 +13,10 @@ PV = "2.6.34+git${SRCPV}"
# SRC_URI = "git://///path/to/kernel/default_kernel.git;fullclone=1"
SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${WRMACHINE}-${LINUX_KERNEL_TYPE};name=machine \
git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
+
+SRC_URI_append_qemux86-64 = "\
+ file://connect-size.patch \
+ file://qemux86-64.cfg"
WRMACHINE = "${MACHINE}"
@@ -22,11 +26,11 @@ WRMACHINE_qemuppc = "qemu_ppc32"
WRMACHINE_qemumips = "mti_malta32_be"
WRMACHINE_qemuarm = "arm_versatile_926ejs"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
LINUX_VERSION = "v2.6.34"
LINUX_VERSION_EXTENSION = "-wr-${LINUX_KERNEL_TYPE}"
-PR = "r5"
+PR = "r6"
S = "${WORKDIR}/linux"
B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"