aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-04-22 15:20:05 +0100
committerJoshua Lock <josh@linux.intel.com>2010-04-27 18:29:57 +0100
commitc22ab5fc9fd0f18153e73f941f050539d415ff56 (patch)
tree0af352c233ff4524595e924ebb32f72c7a8828db /meta/packages/gcc
parent00c5c9744220ed8a019ede55cdf2809b1d3b72a5 (diff)
downloadopenembedded-core-contrib-c22ab5fc9fd0f18153e73f941f050539d415ff56.tar.gz
Install cross-packages into the native sysroot
Cross is no longer required so can go away, we now install cross packages into the native sysroot and use them from there. This patch includes updates to classes and some recipes which reference CROSS_DIR. Others still need fixing an image can be built and run with this patch applied. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-configure-runtime.inc2
-rw-r--r--meta/packages/gcc/gcc-cross-initial_4.3.3.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb2
-rw-r--r--meta/packages/gcc/gcc-package-cross.inc4
4 files changed, 5 insertions, 5 deletions
diff --git a/meta/packages/gcc/gcc-configure-runtime.inc b/meta/packages/gcc/gcc-configure-runtime.inc
index e20c72fa05..175e08ad14 100644
--- a/meta/packages/gcc/gcc-configure-runtime.inc
+++ b/meta/packages/gcc/gcc-configure-runtime.inc
@@ -11,7 +11,7 @@ RUNTIMETARGET = "libgcc libssp libstdc++-v3"
# libgfortran
do_configure () {
- cp ${CROSS_DIR}/include/gcc-build-internal/* ${S}/gcc
+ cp ${STAGING_DIR_NATIVE}${prefix_native}/include/gcc-build-internal/* ${S}/gcc
for d in ${RUNTIMETARGET}; do
echo "Configuring $d"
mkdir -p ${B}/$d/
diff --git a/meta/packages/gcc/gcc-cross-initial_4.3.3.bb b/meta/packages/gcc/gcc-cross-initial_4.3.3.bb
index 8a429d54fe..2aae639fbc 100644
--- a/meta/packages/gcc/gcc-cross-initial_4.3.3.bb
+++ b/meta/packages/gcc/gcc-cross-initial_4.3.3.bb
@@ -5,6 +5,6 @@ PR = "r1"
# Hack till we fix *libc properly
do_install_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+ ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include/
}
diff --git a/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb b/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb
index 6de46f7e27..eda678ef2f 100644
--- a/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb
+++ b/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb
@@ -4,6 +4,6 @@ PR = "r1"
# Hack till we fix *libc properly
do_install_append() {
- ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+ ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include/
}
diff --git a/meta/packages/gcc/gcc-package-cross.inc b/meta/packages/gcc/gcc-package-cross.inc
index 396631edd6..04ae78a88b 100644
--- a/meta/packages/gcc/gcc-package-cross.inc
+++ b/meta/packages/gcc/gcc-package-cross.inc
@@ -8,8 +8,8 @@ do_install () {
# Link gfortran to g77 to satisfy not-so-smart configure or hard coded g77
# gfortran is fully backwards compatible. This is a safe and practical solution.
- ln -sf ${CROSS_DIR}/bin/${TARGET_PREFIX}gfortran ${CROSS_DIR}/bin/${TARGET_PREFIX}g77 || true
- ln -sf ${CROSS_DIR}/${TARGET_SYS}/bin/gfortran ${CROSS_DIR}/${TARGET_SYS}/bin/g77 || true
+ ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/bin/${TARGET_PREFIX}gfortran ${STAGING_DIR_NATIVE}${prefix_native}/bin/${TARGET_PREFIX}g77 || true
+ ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin/gfortran ${STAGING_DIR_NATIVE}/${prefix_native}/${TARGET_SYS}/bin/g77 || true
# Remove things we don't need but keep share/java
for d in info man share/doc share/locale share/man share/info; do