aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-09-16 23:09:44 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-09-17 22:24:36 +0100
commitaf85ce4b4e675feb5796f87137c86d70c2f15b9a (patch)
treef19dbb9bcf1eec671b26685458f7cc47ebb3721e /meta/packages/gcc
parent046ae6a38d829048663fe1afb1f67de1fbe2e3b5 (diff)
downloadopenembedded-core-contrib-af85ce4b4e675feb5796f87137c86d70c2f15b9a.tar.gz
Remove layout_* variables
Remove layout_* variables and replace them with variables specific to the different classes. The layout variables were only useful for the native/cross classes and caused more confusion than they solved. They didn't scale to the sdk class. It now clear a small set of native/cross variables fulfil the needs. This patch also changes native.bbclass to use "/" as the STAGING_DIR which makes sense since we're installing binaries into the locations we're compiling them for. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-configure-cross.inc8
-rw-r--r--meta/packages/gcc/gcc-configure-sdk.inc4
-rw-r--r--meta/packages/gcc/gcc-configure-target.inc2
-rw-r--r--meta/packages/gcc/gcc-cross-initial.inc2
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate.inc2
-rw-r--r--meta/packages/gcc/gcc-cross-sdk_4.1.2.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-sdk_4.2.3.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-sdk_4.3.1.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-sdk_4.3.3.bb2
-rw-r--r--meta/packages/gcc/gcc-cross.inc1
-rw-r--r--meta/packages/gcc/gcc-cross_4.1.2.bb4
-rw-r--r--meta/packages/gcc/gcc-cross_4.2.3.bb4
-rw-r--r--meta/packages/gcc/gcc-cross_4.3.1.bb4
-rw-r--r--meta/packages/gcc/gcc-cross_4.3.2.bb4
-rw-r--r--meta/packages/gcc/gcc-cross_4.3.3.bb4
-rw-r--r--meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb8
-rw-r--r--meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb8
-rw-r--r--meta/packages/gcc/gcc-native.inc2
18 files changed, 33 insertions, 32 deletions
diff --git a/meta/packages/gcc/gcc-configure-cross.inc b/meta/packages/gcc/gcc-configure-cross.inc
index 5befaa8c67..8a47a45bc9 100644
--- a/meta/packages/gcc/gcc-configure-cross.inc
+++ b/meta/packages/gcc/gcc-configure-cross.inc
@@ -2,8 +2,8 @@ require gcc-configure-common.inc
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
-EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
- --with-gxx-include-dir=${STAGING_DIR_TARGET}/${layout_includedir}/c++ \
+EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
+ --with-gxx-include-dir=${STAGING_DIR_TARGET}/${target_includedir}/c++ \
--with-sysroot=${STAGING_DIR_TARGET} \
--with-build-sysroot=${STAGING_DIR_TARGET}"
@@ -31,8 +31,8 @@ do_stage_append () {
rmdir ${CROSS_DIR}/include || :
# Move libssp into staging
- install -d ${STAGING_DIR_TARGET}${layout_base_libdir}/
- mv ${CROSS_DIR}/${TARGET_SYS}/lib/libssp* ${STAGING_DIR_TARGET}${layout_base_libdir}/ || true
+ install -d ${STAGING_DIR_TARGET}${target_base_libdir}/
+ mv ${CROSS_DIR}/${TARGET_SYS}/lib/libssp* ${STAGING_DIR_TARGET}${target_base_libdir}/ || true
# We don't really need to keep this around
# rm -rf ${CROSS_DIR}/share but leave java there
diff --git a/meta/packages/gcc/gcc-configure-sdk.inc b/meta/packages/gcc/gcc-configure-sdk.inc
index ddaa041ee9..c04b93e568 100644
--- a/meta/packages/gcc/gcc-configure-sdk.inc
+++ b/meta/packages/gcc/gcc-configure-sdk.inc
@@ -4,8 +4,8 @@ require gcc-configure-common.inc
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}'
-EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
- --with-gxx-include-dir=${prefix}/${TARGET_SYS}${layout_includedir}/c++/${BINV}/ \
+EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
+ --with-gxx-include-dir=${prefix}/${TARGET_SYS}${target_includedir}/c++/${BINV}/ \
--with-sysroot=${prefix}/${TARGET_SYS} \
--with-build-sysroot=${STAGING_DIR_TARGET}"
diff --git a/meta/packages/gcc/gcc-configure-target.inc b/meta/packages/gcc/gcc-configure-target.inc
index a3e274522c..44d6136240 100644
--- a/meta/packages/gcc/gcc-configure-target.inc
+++ b/meta/packages/gcc/gcc-configure-target.inc
@@ -1,6 +1,6 @@
require gcc-configure-common.inc
EXTRA_OECONF_PATHS = " \
- --with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
+ --with-local-prefix=${STAGING_DIR_TARGET}${prefix} \
--with-gxx-include-dir=${includedir}/c++/${BINV}/"
diff --git a/meta/packages/gcc/gcc-cross-initial.inc b/meta/packages/gcc/gcc-cross-initial.inc
index 15e5fa62fc..a2c4445578 100644
--- a/meta/packages/gcc/gcc-cross-initial.inc
+++ b/meta/packages/gcc/gcc-cross-initial.inc
@@ -4,7 +4,7 @@ PACKAGES = ""
# This is intended to be a -very- basic config
# sysroot is needed in case we use libc-initial
-EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
+EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
--with-newlib \
--without-headers \
--disable-shared \
diff --git a/meta/packages/gcc/gcc-cross-intermediate.inc b/meta/packages/gcc/gcc-cross-intermediate.inc
index 4fa12886f1..57fa949485 100644
--- a/meta/packages/gcc/gcc-cross-intermediate.inc
+++ b/meta/packages/gcc/gcc-cross-intermediate.inc
@@ -5,7 +5,7 @@ PACKAGES = ""
# This is intended to be a -very- basic config
# sysroot is needed in case we use libc-initial
-EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
+EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
--enable-shared \
--disable-multilib \
--disable-threads \
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb b/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb
index 616a5831d0..83f0ec865b 100644
--- a/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb
+++ b/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb
@@ -7,4 +7,4 @@ require gcc-package-sdk.inc
DEPENDS += "gmp-native mpfr-native"
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb b/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb
index 7e3a459ea8..8cca9f8f06 100644
--- a/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb
+++ b/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb
@@ -11,4 +11,4 @@ DEPENDS += "gmp-native mpfr-native"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
- --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb b/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb
index 9562b43fdc..94a95de407 100644
--- a/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb
+++ b/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb
@@ -11,7 +11,7 @@ DEPENDS += "gmp-sdk mpfr-sdk"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
- --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
# to find libmpfr
export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb b/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb
index 9562b43fdc..65df556e8c 100644
--- a/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb
+++ b/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb
@@ -11,7 +11,7 @@ DEPENDS += "gmp-sdk mpfr-sdk"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
- --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+ --with-mpfr=${STAGING_DIR_NATIVE}${native_prefix}"
# to find libmpfr
export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
diff --git a/meta/packages/gcc/gcc-cross.inc b/meta/packages/gcc/gcc-cross.inc
index 3fa6f61f0d..3485824b8a 100644
--- a/meta/packages/gcc/gcc-cross.inc
+++ b/meta/packages/gcc/gcc-cross.inc
@@ -5,6 +5,7 @@
target_libdir := "${libdir}"
target_includedir := "${includedir}"
target_base_libdir := "${base_libdir}"
+target_prefix := "${prefix}"
inherit cross
diff --git a/meta/packages/gcc/gcc-cross_4.1.2.bb b/meta/packages/gcc/gcc-cross_4.1.2.bb
index c9e3279ffc..d37ca6653c 100644
--- a/meta/packages/gcc/gcc-cross_4.1.2.bb
+++ b/meta/packages/gcc/gcc-cross_4.1.2.bb
@@ -9,6 +9,6 @@ SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
EXTRA_OECONF_append_avr32= " --disable-libmudflap "
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/packages/gcc/gcc-cross_4.2.3.bb b/meta/packages/gcc/gcc-cross_4.2.3.bb
index 72f72835c3..22efffa539 100644
--- a/meta/packages/gcc/gcc-cross_4.2.3.bb
+++ b/meta/packages/gcc/gcc-cross_4.2.3.bb
@@ -7,6 +7,6 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/packages/gcc/gcc-cross_4.3.1.bb b/meta/packages/gcc/gcc-cross_4.3.1.bb
index 11e04594fc..84bee6baf3 100644
--- a/meta/packages/gcc/gcc-cross_4.3.1.bb
+++ b/meta/packages/gcc/gcc-cross_4.3.1.bb
@@ -7,6 +7,6 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/packages/gcc/gcc-cross_4.3.2.bb b/meta/packages/gcc/gcc-cross_4.3.2.bb
index 11e04594fc..84bee6baf3 100644
--- a/meta/packages/gcc/gcc-cross_4.3.2.bb
+++ b/meta/packages/gcc/gcc-cross_4.3.2.bb
@@ -7,6 +7,6 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/packages/gcc/gcc-cross_4.3.3.bb b/meta/packages/gcc/gcc-cross_4.3.3.bb
index 11e04594fc..84bee6baf3 100644
--- a/meta/packages/gcc/gcc-cross_4.3.3.bb
+++ b/meta/packages/gcc/gcc-cross_4.3.3.bb
@@ -7,6 +7,6 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb b/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
index 4fde67b006..b00bebc5c0 100644
--- a/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
+++ b/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
@@ -7,7 +7,7 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
#We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include
CFLAGS = ""
@@ -16,11 +16,11 @@ LDFLAGS = ""
# staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain
do_compile_prepend() {
- ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/
- ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/
+ ln -sf ${STAGING_DIR_TARGET}${target_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/
+ ln -sf ${STAGING_DIR_TARGET}${target_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/
ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/
sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure
}
-ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${layout_libdir} -isystem${STAGING_DIR_TARGET}${layout_includedir}"
+ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${target_libdir} -isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb b/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb
index 01b5bdacc4..a1581c2aa1 100644
--- a/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb
+++ b/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb
@@ -7,7 +7,7 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
#We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include
CFLAGS = ""
@@ -16,11 +16,11 @@ LDFLAGS = ""
# staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain
do_compile_prepend() {
- ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/
- ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/
+ ln -sf ${STAGING_DIR_TARGET}${target_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/
+ ln -sf ${STAGING_DIR_TARGET}${target_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/
ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/
sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure
}
-ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${layout_libdir} -isystem${STAGING_DIR_TARGET}${layout_includedir}"
+ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${target_libdir} -isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/packages/gcc/gcc-native.inc b/meta/packages/gcc/gcc-native.inc
index 6fa615ffc7..63b7375e96 100644
--- a/meta/packages/gcc/gcc-native.inc
+++ b/meta/packages/gcc/gcc-native.inc
@@ -5,7 +5,7 @@ PROVIDES = "gcc-native-${PV}"
inherit native
# This is intended to be a -very- basic config
-EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
+EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${prefix} \
--with-newlib \
--disable-shared \
--disable-threads \