aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-07-25 15:04:35 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-25 15:04:35 +0100
commit7a18558925f2c2098f0af77410371caf2c374942 (patch)
tree43cb74b747dca917b606fd225b4fbcfb6b525f55 /meta/packages/gcc
parent43b8e664673523c803a6993b9b5a582cdc889afd (diff)
downloadopenembedded-core-contrib-7a18558925f2c2098f0af77410371caf2c374942.tar.gz
gcc: For 64 bit targets don't use lib64
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-4.3.3.inc1
-rw-r--r--meta/packages/gcc/gcc-4.3.3/64bithack.patch20
-rw-r--r--meta/packages/gcc/gcc-crosssdk-initial_4.3.3.bb1
-rw-r--r--meta/packages/gcc/gcc-crosssdk-intermediate_4.3.3.bb2
4 files changed, 23 insertions, 1 deletions
diff --git a/meta/packages/gcc/gcc-4.3.3.inc b/meta/packages/gcc/gcc-4.3.3.inc
index 73783e689f..9b600a0f1f 100644
--- a/meta/packages/gcc/gcc-4.3.3.inc
+++ b/meta/packages/gcc/gcc-4.3.3.inc
@@ -55,6 +55,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://pr35942.patch;patch=1 \
file://optional_libstdc.patch;patch=1 \
file://sparseset_rule.patch;patch=1 \
+ file://64bithack.patch;patch=1 \
"
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
diff --git a/meta/packages/gcc/gcc-4.3.3/64bithack.patch b/meta/packages/gcc/gcc-4.3.3/64bithack.patch
new file mode 100644
index 0000000000..ac65e01afa
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.3/64bithack.patch
@@ -0,0 +1,20 @@
+By default gcc places 64 bit libs in a lib64 directory. This makes it use
+"lib" instead.
+
+RP 25/7/10
+
+Index: gcc-4.3.3/gcc/config/i386/t-linux64
+===================================================================
+--- gcc-4.3.3.orig/gcc/config/i386/t-linux64 2010-07-25 12:26:36.000000000 +0100
++++ gcc-4.3.3/gcc/config/i386/t-linux64 2010-07-25 13:43:02.000000000 +0100
+@@ -12,8 +12,8 @@
+ # MULTILIB_OSDIRNAMES according to what is found on the target.
+
+ MULTILIB_OPTIONS = m64/m32
+-MULTILIB_DIRNAMES = 64 32
+-MULTILIB_OSDIRNAMES = ../lib64 $(if $(wildcard $(shell echo $(SYSTEM_HEADER_DIR))/../../usr/lib32),../lib32,../lib)
++MULTILIB_DIRNAMES = . 32
++MULTILIB_OSDIRNAMES = . $(if $(wildcard $(shell echo $(SYSTEM_HEADER_DIR))/../../usr/lib32),../lib32,../lib)
+
+ LIBGCC = stmp-multilib
+ INSTALL_LIBGCC = install-multilib
diff --git a/meta/packages/gcc/gcc-crosssdk-initial_4.3.3.bb b/meta/packages/gcc/gcc-crosssdk-initial_4.3.3.bb
index 0c9fdd3449..8d86e414ce 100644
--- a/meta/packages/gcc/gcc-crosssdk-initial_4.3.3.bb
+++ b/meta/packages/gcc/gcc-crosssdk-initial_4.3.3.bb
@@ -1,2 +1,3 @@
require gcc-cross-initial_${PV}.bb
require gcc-crosssdk-initial.inc
+PR = "r2"
diff --git a/meta/packages/gcc/gcc-crosssdk-intermediate_4.3.3.bb b/meta/packages/gcc/gcc-crosssdk-intermediate_4.3.3.bb
index b14dfc32cf..e11e064386 100644
--- a/meta/packages/gcc/gcc-crosssdk-intermediate_4.3.3.bb
+++ b/meta/packages/gcc/gcc-crosssdk-intermediate_4.3.3.bb
@@ -1,3 +1,3 @@
require gcc-cross-intermediate_${PV}.bb
require gcc-crosssdk-intermediate.inc
-PR = "r2"
+PR = "r5"