aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/fakeroot/fakeroot_1.14.4.bb
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-07-07 19:15:40 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 21:05:41 -0700
commit43bd7936793701839df4dd4e49ef91985ee11e06 (patch)
tree9e3da8c4025a0aec1b544a1f39ce8cf520e06795 /meta/packages/fakeroot/fakeroot_1.14.4.bb
parent59df5a4b2dd2696f34c074d11b15ed18cc6bea65 (diff)
downloadopenembedded-core-contrib-43bd7936793701839df4dd4e49ef91985ee11e06.tar.gz
fakeroot: upgrade to 1.14.4
[Patches] KEEP _absolutepaths.patch_: solve python link issue REMOVE _configure-libtool.patch_: an old patch, not required now [Recipe] manually create build-aux since its own bootstrap contains more than we want Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/fakeroot/fakeroot_1.14.4.bb')
-rw-r--r--meta/packages/fakeroot/fakeroot_1.14.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot_1.14.4.bb b/meta/packages/fakeroot/fakeroot_1.14.4.bb
new file mode 100644
index 0000000000..11ae015a83
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot_1.14.4.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Provides a fake \"root environment\" by means of LD_PRELOAD and SYSV IPC or TCP trickery"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPLv2"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+RDEPENDS_virtclass-native = "util-linux-native"
+PR = "r0"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
+ file://absolutepaths.patch"
+
+inherit autotools
+
+do_configure_prepend() {
+ # fakeroot's own bootstrap includes other autoreconf stuff we don't need here
+ # so manually create the aux directory
+ mkdir -p ${S}/build-aux
+}
+
+do_install_append() {
+ install -d ${D}${STAGING_INCDIR}/fakeroot/
+ install -m 644 *.h ${D}${STAGING_INCDIR}/fakeroot
+}
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
+}
+
+BBCLASSEXTEND = "native"