aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/chrpath/chrpath_0.13.bb
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-02-11 16:11:01 +0000
committerJoshua Lock <josh@linux.intel.com>2010-02-11 16:21:09 +0000
commit6e1cc7ca104b78ebb34a15eb4a41e33c7186d2fd (patch)
tree0f47b358ce2f5e26c43777c79409274eeb218a17 /meta/packages/chrpath/chrpath_0.13.bb
parenta0795895e317fddb212dc531e2ac8943f433c562 (diff)
downloadopenembedded-core-contrib-6e1cc7ca104b78ebb34a15eb4a41e33c7186d2fd.tar.gz
relocatable.bbclass: remove hard-coded rpaths from native binaries
The relocatable path will pre-process built binaries in SYSROOT_DESTDIR and replace any harcoded dynamic link rpaths with relative paths. Add an inherit of class in native.bbclass to make our native packages relocatable and tweak the chrpath recipe so that the native package can make itself relocatable with the just built chrpath binary. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/chrpath/chrpath_0.13.bb')
-rw-r--r--meta/packages/chrpath/chrpath_0.13.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/packages/chrpath/chrpath_0.13.bb b/meta/packages/chrpath/chrpath_0.13.bb
index e843de6872..012897d575 100644
--- a/meta/packages/chrpath/chrpath_0.13.bb
+++ b/meta/packages/chrpath/chrpath_0.13.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "chrpath allows you to change the rpath (where the application \
looks for libraries) in an application. It does not (yet) allow you to add an \
rpath if there isn't one already."
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/c/chrpath/chrpath_${PV}.orig.tar.gz"
@@ -9,4 +10,8 @@ inherit autotools
S = "${WORKDIR}/chrpath-${PV}"
+# We don't have a staged chrpath-native for ensuring our binary is relocatable
+# so must use the one we've just built
+CHRPATH_BIN = "${S}/chrpath"
+
BBCLASSEXTEND = "native"