summaryrefslogtreecommitdiffstats
path: root/meta/lib
diff options
context:
space:
mode:
authorYoann Congal <yoann.congal@smile.fr>2020-10-09 09:15:45 +0200
committerSteve Sakoman <steve@sakoman.com>2020-10-19 04:27:15 -1000
commit2387f968b8dd90de9f0907ee571ec6207ffa9a19 (patch)
tree9ad93891a0451b2d505513779e523726c6125b97 /meta/lib
parente2240d0a93a9a2932506a356315ad6702ecee9b6 (diff)
downloadopenembedded-core-contrib-2387f968b8dd90de9f0907ee571ec6207ffa9a19.tar.gz
bitbake-bblayers/create: Make the example recipe print its message
The example recipe is setup to print a message using bb.plain() in the "do_build" task but this task is "noexec" so the message never prints. This might be confusing. This moves the message printing into another "do_display_banner" task and add it to the do_build "before" list. Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 252385bef9b226f32691b8513869ea3e41813b40) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/lib')
-rw-r--r--meta/lib/bblayers/templates/example.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/lib/bblayers/templates/example.bb b/meta/lib/bblayers/templates/example.bb
index c4b873d593..facaae35d2 100644
--- a/meta/lib/bblayers/templates/example.bb
+++ b/meta/lib/bblayers/templates/example.bb
@@ -2,10 +2,12 @@ SUMMARY = "bitbake-layers recipe"
DESCRIPTION = "Recipe created by bitbake-layers"
LICENSE = "MIT"
-python do_build() {
+python do_display_banner() {
bb.plain("***********************************************");
bb.plain("* *");
bb.plain("* Example recipe created by bitbake-layers *");
bb.plain("* *");
bb.plain("***********************************************");
}
+
+addtask display_banner before do_build