aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/selftest/bblayers.py
diff options
context:
space:
mode:
authorCorneliu Stoicescu <corneliux.stoicescu@intel.com>2013-11-27 19:08:53 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-03 12:50:23 +0000
commit8408a7700cd9cab4559ddae0bbe57f0d7fae5c37 (patch)
tree688fc04e76cc179ca031845ce059490a7f9b5b26 /meta/lib/oeqa/selftest/bblayers.py
parent75d2a1a37a18a22b0da7ab5b30cf005c78bc313f (diff)
downloadopenembedded-core-contrib-8408a7700cd9cab4559ddae0bbe57f0d7fae5c37.tar.gz
lib/oeqa/selftest: add test modules for expected bitbake output and bitbake-layers
Tests for bitbake-layers and expected output for some bitbake options. Signed-off-by: Corneliu Stoicescu <corneliux.stoicescu@intel.com> Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa/selftest/bblayers.py')
-rw-r--r--meta/lib/oeqa/selftest/bblayers.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/lib/oeqa/selftest/bblayers.py b/meta/lib/oeqa/selftest/bblayers.py
new file mode 100644
index 0000000000..52aa4f8112
--- /dev/null
+++ b/meta/lib/oeqa/selftest/bblayers.py
@@ -0,0 +1,37 @@
+import unittest
+import os
+import logging
+import re
+import shutil
+
+import oeqa.utils.ftools as ftools
+from oeqa.selftest.base import oeSelfTest
+from oeqa.utils.commands import runCmd
+
+class BitbakeLayers(oeSelfTest):
+
+ def test_bitbakelayers_showcrossdepends(self):
+ result = runCmd('bitbake-layers show-cross-depends')
+ self.assertTrue('aspell' in result.output)
+
+ def test_bitbakelayers_showlayers(self):
+ result = runCmd('bitbake-layers show_layers')
+ self.assertTrue('meta-selftest' in result.output)
+
+ def test_bitbakelayers_showappends(self):
+ result = runCmd('bitbake-layers show_appends')
+ self.assertTrue('xcursor-transparent-theme_0.1.1.bbappend' in result.output, msg='xcursor-transparent-theme_0.1.1.bbappend file was not recognised')
+
+ def test_bitbakelayers_showoverlayed(self):
+ result = runCmd('bitbake-layers show_overlayed')
+ self.assertTrue('aspell' in result.output, msg='xcursor-transparent-theme_0.1.1.bbappend file was not recognised')
+
+ def test_bitbakelayers_flatten(self):
+ self.assertFalse(os.path.isdir(os.path.join(self.builddir, 'test')))
+ result = runCmd('bitbake-layers flatten test')
+ bb_file = os.path.join(self.builddir, 'test/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb')
+ self.assertTrue(os.path.isfile(bb_file))
+ contents = ftools.read_file(bb_file)
+ find_in_contents = re.search("##### bbappended from meta-selftest #####\n(.*\n)*include test_recipe.inc", contents)
+ shutil.rmtree(os.path.join(self.builddir, 'test'))
+ self.assertTrue(find_in_contents)