aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/runtime/kernelmodule.py
diff options
context:
space:
mode:
authorStefan Stanacar <stefanx.stanacar@intel.com>2013-10-18 10:23:44 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-18 15:51:00 +0100
commitc61c3dee162aa1f5bf31b2a09d8b916dc1712056 (patch)
tree7c2d4e6fe517d5283b505c8bfb1292c7055797b8 /meta/lib/oeqa/runtime/kernelmodule.py
parentce6c3ec0e5f4822e85b8f957e9e31fa9de438c55 (diff)
downloadopenembedded-core-contrib-c61c3dee162aa1f5bf31b2a09d8b916dc1712056.tar.gz
lib/oeqa/runtime: build kernel module on target test
Builds a simple Hello World module on target. Added to the defaults for core-image-sato-sdk. Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa/runtime/kernelmodule.py')
-rw-r--r--meta/lib/oeqa/runtime/kernelmodule.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/lib/oeqa/runtime/kernelmodule.py b/meta/lib/oeqa/runtime/kernelmodule.py
new file mode 100644
index 0000000000..cbc5742eff
--- /dev/null
+++ b/meta/lib/oeqa/runtime/kernelmodule.py
@@ -0,0 +1,33 @@
+import unittest
+import os
+from oeqa.oetest import oeRuntimeTest, skipModule
+from oeqa.utils.decorators import *
+
+def setUpModule():
+ if not oeRuntimeTest.hasFeature("tools-sdk"):
+ skipModule("Image doesn't have tools-sdk in IMAGE_FEATURES")
+
+
+class KernelModuleTest(oeRuntimeTest):
+
+ def setUp(self):
+ self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod.c"), "/tmp/hellomod.c")
+ self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod_makefile"), "/tmp/Makefile")
+
+ @skipUnlessPassed('test_ssh')
+ @skipUnlessPassed('test_gcc_compile')
+ def test_kernel_module(self):
+ cmds = [
+ 'cd /usr/src/kernel && make scripts',
+ 'cd /tmp && make',
+ 'cd /tmp && insmod hellomod.ko',
+ 'lsmod | grep hellomod',
+ 'dmesg | grep Hello',
+ 'rmmod hellomod', 'dmesg | grep "Cleaning up hellomod"'
+ ]
+ for cmd in cmds:
+ (status, output) = self.target.run(cmd, 900)
+ self.assertEqual(status, 0, msg="\n".join([cmd, output]))
+
+ def tearDown(self):
+ self.target.run('rm -f /tmp/Makefile /tmp/hellomod.c')