aboutsummaryrefslogtreecommitdiffstats
path: root/meta/conf
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-26 22:22:44 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-26 22:22:44 +0000
commit4952c7e0fede3efbaf5bb9b1e153daa5071ef6a5 (patch)
treef705b0e1e1ea9aa10e4786212eed4a7685362e43 /meta/conf
parent36a7962e7428a79c5bde3f3b0fd36ce3ed19b439 (diff)
downloadopenembedded-core-contrib-4952c7e0fede3efbaf5bb9b1e153daa5071ef6a5.tar.gz
Totally rework task handling for machine/distro specific features. Create task-base.bb to handle this and update machine/distro files accordingly. MACHINE_FEATURES and DISTRO_FEATURES together combine to configure the machine specific task-base and other specific tasks can easily be created (task-base-oh-minimal is an exmaple)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@562 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/conf')
-rw-r--r--meta/conf/distro/poky.conf2
-rw-r--r--meta/conf/machine/include/handheld-common.conf23
-rw-r--r--meta/conf/machine/include/zaurus-clamshell-2.6.conf42
-rw-r--r--meta/conf/machine/ipaq-pxa270.conf7
-rw-r--r--meta/conf/machine/spitz.conf4
5 files changed, 12 insertions, 66 deletions
diff --git a/meta/conf/distro/poky.conf b/meta/conf/distro/poky.conf
index 4218ce80bc..4bfe462a40 100644
--- a/meta/conf/distro/poky.conf
+++ b/meta/conf/distro/poky.conf
@@ -171,3 +171,5 @@ PCMCIA_MANAGER ?= "pcmciautils"
CVS_TARBALL_STASH += "http://www.o-hand.com/~richard/poky/sources/"
IMAGE_LINGUAS = "en-gb"
+
+DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi"
diff --git a/meta/conf/machine/include/handheld-common.conf b/meta/conf/machine/include/handheld-common.conf
deleted file mode 100644
index f8767d2ddf..0000000000
--- a/meta/conf/machine/include/handheld-common.conf
+++ /dev/null
@@ -1,23 +0,0 @@
-HANDHELD_MODULES = "ipv6 \
-ipsec \
-nvrd \
-mip6-mn \
-tun \
-ide-cs ide-disk ide-probe-mod \
-loop \
-vfat ext2 \
-sunrpc nfs \
-btuart-cs dtl1-cs bt3c-cs rfcomm bnep l2cap sco hci_uart hidp \
-pcnet-cs serial-cs airo-cs \
-af_packet \
-ppp-async ppp-deflate ppp-mppe \
-ip-gre ip-tables ipip \
-irda irlan irnet irport irtty ircomm-tty \
-input uinput \
-"
-
-# Configuration bits for "generic handheld"
-BOOTSTRAP_EXTRA_RDEPENDS += "${PCMCIA_MANAGER} apm apmd network-suspend-scripts"
-BOOTSTRAP_EXTRA_RRECOMMENDS += "ppp wireless-tools irda-utils openswan wpa-supplicant-nossl lrzsz ppp-dialin ${@linux_module_packages('${HANDHELD_MODULES}', d)}"
-
-INHERIT += "linux_modules"
diff --git a/meta/conf/machine/include/zaurus-clamshell-2.6.conf b/meta/conf/machine/include/zaurus-clamshell-2.6.conf
index 3c19ef3da6..fa2adda6fb 100644
--- a/meta/conf/machine/include/zaurus-clamshell-2.6.conf
+++ b/meta/conf/machine/include/zaurus-clamshell-2.6.conf
@@ -6,41 +6,13 @@ PREFERRED_VERSION_wpa_supplicant = "0.4.7"
PCMCIA_MANAGER ?= "pcmciautils"
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel udev sysfsutils spectrum-fw \
-${PCMCIA_MANAGER} apm wireless-tools irda-utils udev-utils keymaps hostap-utils prism3-firmware prism3-support \
-ppp ppp-dialin openswan wpa-supplicant-nossl alsa-utils-alsactl alsa-utils-alsamixer module-init-tools alsa-conf zaurusd"
+MACHINE_FEATURES = "kernel26 apm alsa pcmcia bluetooth irda usbgadget"
+MACHINE_FEATURES_akita = "kernel26 apm alsa pcmcia bluetooth irda usbgadget usbhost"
+MACHINE_FEATURES_spitz = "kernel26 apm alsa pcmcia bluetooth irda usbgadget usbhost ext2"
-# Ethernet modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-pcnet-cs"
-# NFS Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-nfs kernel-module-lockd kernel-module-sunrpc"
-# Crypto Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-des kernel-module-md5"
-# SMB and CRAMFS
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-smbfs kernel-module-cramfs"
-# Serial Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-8250 kernel-module-serial-cs"
-# Bluetooth Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-bluetooth kernel-module-l2cap kernel-module-rfcomm kernel-module-hci-vhci \
- kernel-module-bnep kernel-module-hidp kernel-module-hci-uart kernel-module-sco \
- kernel-module-bt3c-cs kernel-module-bluecard-cs kernel-module-btuart-cs kernel-module-dtl1-cs"
-# Infrared Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-pxaficp-ir kernel-module-irda kernel-module-ircomm \
- kernel-module-ircomm-tty kernel-module-irlan kernel-module-irnet kernel-module-ir-usb"
-# USB Gadget Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-gadgetfs kernel-module-g-file-storage \
- kernel-module-g-serial kernel-module-g-ether"
+MACHINE_EXTRA_RDEPENDS = "zaurusd"
+MACHINE_EXTRA_RRECOMMENDS_c7x0 = "kernel-module-snd-soc-corgi"
+MACHINE_EXTRA_RRECOMMENDS_akita = "kernel-module-snd-soc-spitz"
+MACHINE_EXTRA_RRECOMMENDS_spitz = "kernel-module-snd-soc-spitz"
-# Wireless Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-hostap kernel-module-hostap-cs \
- kernel-module-hermes kernel-module-orinoco \
- kernel-module-orinoco-cs kernel-module-spectrum-cs \
- hostap-conf orinoco-conf"
-
-# Sound Modules
-BOOTSTRAP_EXTRA_RDEPENDS_append_c7x0 = " kernel-module-snd-soc-corgi "
-BOOTSTRAP_EXTRA_RDEPENDS_append_akita = " kernel-module-snd-soc-spitz "
-BOOTSTRAP_EXTRA_RDEPENDS_append_spitz = " kernel-module-snd-soc-spitz "
-# For OSS
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-snd-mixer-oss kernel-module-snd-pcm-oss" \ No newline at end of file
diff --git a/meta/conf/machine/ipaq-pxa270.conf b/meta/conf/machine/ipaq-pxa270.conf
index ffa8b2d9c5..1aeb8f3f2b 100644
--- a/meta/conf/machine/ipaq-pxa270.conf
+++ b/meta/conf/machine/ipaq-pxa270.conf
@@ -4,11 +4,9 @@
TARGET_ARCH = "arm"
IPKG_EXTRA_ARCHS = "armv4 armv5te ipaqpxa hx4700"
-#use this for a hx47xx ipaq
-PREFERRED_PROVIDER_virtual/kernel = "handhelds-pxa-2.6"
#use this for a hx2xxx ipaq
-#PREFERRED_PROVIDER_virtual/kernel = "linux-openzaurus"
+PREFERRED_PROVIDER_virtual/kernel = "linux-openzaurus"
PREFERRED_VERSION_orinoco-modules = "0.15rc1"
@@ -42,7 +40,8 @@ include conf/machine/include/tune-xscale.conf
# Uncomment this to use iwmmxt optimizations. Remove the above xscale stuff first
#include conf/machine/include/tune-iwmmxt.conf
-BOOTSTRAP_EXTRA_RRECOMMENDS += "${@linux_module_packages('${HX4700_MODULES}', d)}"
+BOOTSTRAP_EXTRA_RRECOMMENDS += ""
+#${@linux_module_packages('${HX4700_MODULES}', d)}
HX4700_MODULES = "i2c-pxa asic3_mmc hx4700_bt hx4700_leds hx4700_navpt hx4700_pcmcia \
hx4700_ts hx4700_wlan snd_hx4700_audio hx4700_power"
diff --git a/meta/conf/machine/spitz.conf b/meta/conf/machine/spitz.conf
index f8b0572b42..6588702a84 100644
--- a/meta/conf/machine/spitz.conf
+++ b/meta/conf/machine/spitz.conf
@@ -6,10 +6,6 @@ include conf/machine/include/zaurus-clamshell.conf
include conf/machine/include/zaurus-clamshell-2.6.conf
PIVOTBOOT_EXTRA_RDEPENDS += "pivotinit ${PCMCIA_MANAGER}"
-PIVOTBOOT_EXTRA_RRECOMMENDS += ""
-
-# Useful things for the built-in Harddisk
-BOOTSTRAP_EXTRA_RDEPENDS += "hdparm e2fsprogs e2fsprogs-e2fsck e2fsprogs-mke2fs"
IMAGE_FSTYPES ?= "tar.gz"