summaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-08 14:30:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-09 11:46:23 +0000
commitf85b512e2ad39ec32f11f9b25b8c92bea20c844d (patch)
treeceac24e227deba1c6617835b5ba1b12e5816ed73 /meta/classes
parenta3d9eb8051bc2effb8130b1743ba251c1fe7c525 (diff)
downloadopenembedded-core-contrib-f85b512e2ad39ec32f11f9b25b8c92bea20c844d.tar.gz
flit_core: add variable to control where pyproject.toml is located
The PEP517[1] pyproject.toml doesn't have to be located at the top-level of the source tree (for example, in recipes with multiple components), so add a variable PEP517_SOURCE_PATH to set where the file is. In the future there should be a pep517.bbclass to centralise the common logic, but for now this can be defined in each of the relevant classes. [1] https://www.python.org/dev/peps/pep-0517/ Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/flit_core.bbclass4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/classes/flit_core.bbclass b/meta/classes/flit_core.bbclass
index 3481bb5089..7b578967a9 100644
--- a/meta/classes/flit_core.bbclass
+++ b/meta/classes/flit_core.bbclass
@@ -6,8 +6,12 @@ flit_core_do_configure () {
:
}
+# Where to execute the build process from
+PEP517_SOURCE_PATH ?= "${S}"
+
# TODO: ideally this uses pypa/build
flit_core_do_compile () {
+ cd ${PEP517_SOURCE_PATH}
nativepython3 -mflit_core.wheel --outdir ${PIP_INSTALL_DIST_PATH}
}
do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}"