aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/insane.bbclass
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2009-12-22 17:17:55 +0000
committerJoshua Lock <josh@linux.intel.com>2010-01-04 10:34:00 +0000
commit8a7fd14ad424a235e7947a5bbb4b9531464f6ba8 (patch)
tree8b959dd6b6403f0b8ec84d291cc3be5c0acf05bb /meta/classes/insane.bbclass
parent91d2e7d1bc725f2c3a39b4c7413bf96e85d17375 (diff)
downloadopenembedded-core-contrib-8a7fd14ad424a235e7947a5bbb4b9531464f6ba8.tar.gz
insane.bbclass: special case gettext as it can't depend on itself
Only run the gettext section of the QA configure sanity check if the package is not gettext as the gettext tools, shipped with gettext, use the macro employed in the sanity check. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/classes/insane.bbclass')
-rw-r--r--meta/classes/insane.bbclass21
1 files changed, 11 insertions, 10 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 9fc8873f22..9bddb9bd42 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -500,14 +500,15 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
if "configure.in" in files:
configs.append(os.path.join(root, "configure.in"))
- if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
- gt = "gettext-native"
- else:
- gt = "gettext"
- deps = bb.utils.explode_deps(bb.data.getVar('DEPENDS', d, True) or "")
- if gt not in deps:
- for config in configs:
- gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config
- if os.system(gnu) == 0:
- bb.fatal("Gettext required but not in DEPENDS for file %s" % config)
+ if "gettext" not in bb.data.getVar('P', d, True):
+ if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
+ gt = "gettext-native"
+ else:
+ gt = "gettext"
+ deps = bb.utils.explode_deps(bb.data.getVar('DEPENDS', d, True) or "")
+ if gt not in deps:
+ for config in configs:
+ gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config
+ if os.system(gnu) == 0:
+ bb.fatal("Gettext required but not in DEPENDS for file %s" % config)
}