aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/insane.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-03 16:58:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 13:12:18 +0000
commitac24487a05834cc9c02a95bbd281927d98c5886e (patch)
treee8d79d080e2be6fc2a6ceb89b5a4f00c40c9d332 /meta/classes/insane.bbclass
parent316228948e65f376f6c5be13ccd0c964ea630edf (diff)
downloadopenembedded-core-contrib-ac24487a05834cc9c02a95bbd281927d98c5886e.tar.gz
insane.bbclass: Add documentation headers for logical code blocks
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/insane.bbclass')
-rw-r--r--meta/classes/insane.bbclass17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 3375a41ff6..1905c0dfdd 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -836,6 +836,10 @@ python do_qa_staging() {
python do_qa_configure() {
import subprocess
+ ###########################################################################
+ # Check config.log for cross compile issues
+ ###########################################################################
+
configs = []
workdir = d.getVar('WORKDIR', True)
bb.note("Checking autotools environment for common misconfiguration")
@@ -852,6 +856,10 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
if "configure.in" in files:
configs.append(os.path.join(root, "configure.in"))
+ ###########################################################################
+ # Check gettext configuration and dependencies are correct
+ ###########################################################################
+
cnf = d.getVar('EXTRA_OECONF', True) or ""
if "gettext" not in d.getVar('P', True) and "gcc-runtime" not in d.getVar('P', True) and "--disable-nls" not in cnf:
ml = d.getVar("MLPREFIX", True) or ""
@@ -869,8 +877,13 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
bb.fatal("""%s required but not in DEPENDS for file %s.
Missing inherit gettext?""" % (gt, config))
+ ###########################################################################
+ # Check license variables
+ ###########################################################################
+
if not package_qa_check_license(workdir, d):
bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix")
+
}
# The Staging Func, to check all staging
#addtask qa_staging after do_populate_sysroot before do_build
@@ -886,6 +899,10 @@ python () {
if "desktop" in tests:
d.appendVar("PACKAGE_DEPENDS", "desktop-file-utils-native")
+ ###########################################################################
+ # Check various variables
+ ###########################################################################
+
issues = []
if (d.getVar('PACKAGES', True) or "").split():
for var in 'RDEPENDS', 'RRECOMMENDS', 'FILES', 'pkg_preinst', 'pkg_postinst', 'pkg_prerm', 'pkg_postrm':