aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/image.bbclass
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-07-26 08:30:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 11:54:53 +0100
commitb3ff63796cd6629975ff0a726ba18cc168e0a2b2 (patch)
tree7efc20a3ed129bc51de47502369863a5acbd7865 /meta/classes/image.bbclass
parent190b4f17f5fc9879e680278dd0e31e26e5f5bca0 (diff)
downloadopenembedded-core-contrib-b3ff63796cd6629975ff0a726ba18cc168e0a2b2.tar.gz
classes/image*: Revamp creation of live images
This creates a live image as an IMAGE_FSTYPES, thus removing the need to have additional -live.bb recipes. To create a live image one just needs to add live to the IMAGE_FSTYPES list Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/classes/image.bbclass')
-rw-r--r--meta/classes/image.bbclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index edfb2d68c5..79a56f0408 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -29,6 +29,9 @@ LDCONFIGDEPEND_libc-uclibc = ""
do_rootfs[depends] += "makedevs-native:do_populate_sysroot virtual/fakeroot-native:do_populate_sysroot ${LDCONFIGDEPEND}"
do_rootfs[depends] += "virtual/update-alternatives-native:do_populate_sysroot update-rc.d-native:do_populate_sysroot"
+IMAGE_TYPE = ${@base_contains("IMAGE_FSTYPES", "live", "live", "empty", d)}
+inherit image-${IMAGE_TYPE}
+
python () {
deps = bb.data.getVarFlag('do_rootfs', 'depends', d) or ""
for type in (bb.data.getVar('IMAGE_FSTYPES', d, True) or "").split():