aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/fontcache.bbclass
diff options
context:
space:
mode:
authorMatthieu Crapet <Matthieu.Crapet@ingenico.com>2014-03-20 10:18:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-21 12:05:28 +0000
commit306335b13fedc18cf03da1c2a68e97c01eb59075 (patch)
treefa0d0897b905fb6a01098d0827a26743ad74030e /meta/classes/fontcache.bbclass
parentff5666bc460520aef6105e117d5431c05fd9f55b (diff)
downloadopenembedded-core-contrib-306335b13fedc18cf03da1c2a68e97c01eb59075.tar.gz
fontcache.bbclass: add fontconfig-utils runtime dependency
In an image recipe, you can get a warning, for example: WARNING: The postinstall intercept hook 'update_font_cache' failed (exit code: 1)! See log for details! WARNING: The postinstalls for the following packages will be postponed for first boot: ttf-dejavu-sans-mono (because /usr/bin/fc-cache is missing) In OE-core, rdepend is correctly done in each recipe: - ttf-fonts/liberation-fonts - ttf-fonts/ttf-bitstream-vera In meta-OE, rdepend is not done but packagegroup-fonts-truetype.bb includes fontconfig-utils: - ttf-fonts/ttf-arphic-uming - ttf-fonts/ttf-dejavu - ttf-fonts/ttf-droid - ttf-fonts/ttf-gentium - ttf-fonts/ttf-hunkyfonts - ttf-fonts/ttf-inconsolata - ttf-fonts/ttf-liberation - ttf-fonts/ttf-mplus - ttf-fonts/ttf-sazanami - ttf-fonts/ttf-ubuntu-font-family - ttf-fonts/ttf-wqy-zenhei Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/fontcache.bbclass')
-rw-r--r--meta/classes/fontcache.bbclass4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/classes/fontcache.bbclass b/meta/classes/fontcache.bbclass
index 325bcae58f..afd3fd2252 100644
--- a/meta/classes/fontcache.bbclass
+++ b/meta/classes/fontcache.bbclass
@@ -7,6 +7,7 @@ DEPENDS += "qemu-native"
inherit qemu
FONT_PACKAGES ??= "${PN}"
+FONT_EXTRA_RDEPENDS ?= "fontconfig-utils"
fontcache_common() {
if [ "x$D" != "x" ] ; then
@@ -19,8 +20,11 @@ fi
python populate_packages_append() {
font_pkgs = d.getVar('FONT_PACKAGES', True).split()
+ deps = d.getVar("FONT_EXTRA_RDEPENDS", True)
for pkg in font_pkgs:
+ if deps: d.appendVar('RDEPENDS_' + pkg, ' '+deps)
+
bb.note("adding fonts postinst and postrm scripts to %s" % pkg)
postinst = d.getVar('pkg_postinst_%s' % pkg, True) or d.getVar('pkg_postinst', True)
if not postinst: