aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/archiver.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 13:08:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-19 12:24:05 +0100
commit7d674820958be3a7051ea619effe1a6061d9cbe2 (patch)
tree5ca9163652717746c8c79a88dbd0bcb047eea558 /meta/classes/archiver.bbclass
parentca30b6587841f5e9a42aaedb8e0b89ff5a4a6a37 (diff)
downloadopenembedded-core-contrib-7d674820958be3a7051ea619effe1a6061d9cbe2.tar.gz
Remove a number of unneeded import os/bb calls
The bb and os modules are always imported so having these extra import calls are a waste of space/execution time. They also set a bad example for people copy and pasting code so clean them up. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/archiver.bbclass')
-rw-r--r--meta/classes/archiver.bbclass3
1 files changed, 0 insertions, 3 deletions
diff --git a/meta/classes/archiver.bbclass b/meta/classes/archiver.bbclass
index 2b5404f1da..8e97e447c9 100644
--- a/meta/classes/archiver.bbclass
+++ b/meta/classes/archiver.bbclass
@@ -76,7 +76,6 @@ def tar_filter(d):
def get_bb_inc(d):
'''create a directory "script-logs" including .bb and .inc file in ${WORKDIR}'''
import re
- import os
import shutil
bbinc = []
@@ -154,7 +153,6 @@ def get_series(d):
def get_applying_patches(d):
"""only copy applying patches to a pointed directory which will be archived to tarball"""
- import os
import shutil
@@ -174,7 +172,6 @@ def get_applying_patches(d):
def not_tarball(d):
'''packages including key words 'work-shared','native', 'task-' will be passed'''
- import os
workdir = d.getVar('WORKDIR',True)
s = d.getVar('S',True)