aboutsummaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-09-06 16:26:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-14 22:22:41 +0100
commitde915fb7d387a7a3dcaba61b6e116bb28db9d8ff (patch)
treefb1f792035ca908f49e8dada135b11f5bcdefb66 /meta-yocto-bsp
parent56a490027342a8847ccf7bec50f616880acfd369 (diff)
downloadopenembedded-core-contrib-de915fb7d387a7a3dcaba61b6e116bb28db9d8ff.tar.gz
linux-yocto: Adds new bbappend for genericx86 and genericx86-64 BSPs to support kernel 4.8
(From meta-yocto rev: a96837d7bc42b8710ca5ac687191f03540279fad) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/genericx86-64.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/genericx86.conf2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.8.bbappend14
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-yocto-bsp/conf/machine/genericx86-64.conf b/meta-yocto-bsp/conf/machine/genericx86-64.conf
index f76e35af67..ceee247bac 100644
--- a/meta-yocto-bsp/conf/machine/genericx86-64.conf
+++ b/meta-yocto-bsp/conf/machine/genericx86-64.conf
@@ -6,3 +6,5 @@
DEFAULTTUNE ?= "core2-64"
require conf/machine/include/tune-core2.inc
require conf/machine/include/genericx86-common.inc
+
+PREFERRED_VERSION_linux-yocto_genericx86-64 ?= "4.8%"
diff --git a/meta-yocto-bsp/conf/machine/genericx86.conf b/meta-yocto-bsp/conf/machine/genericx86.conf
index 798b62ec2b..04a7e0b6ad 100644
--- a/meta-yocto-bsp/conf/machine/genericx86.conf
+++ b/meta-yocto-bsp/conf/machine/genericx86.conf
@@ -8,3 +8,5 @@ require conf/machine/include/tune-core2.inc
require conf/machine/include/genericx86-common.inc
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "gma500-gfx-check"
+
+PREFERRED_VERSION_linux-yocto_genericx86 ?= "4.8%"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.8.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.8.bbappend
new file mode 100644
index 0000000000..efa11cb209
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.8.bbappend
@@ -0,0 +1,14 @@
+KBRANCH_genericx86 = "standard/base"
+KBRANCH_genericx86-64 = "standard/base"
+
+KMACHINE_genericx86 ?= "common-pc"
+KMACHINE_genericx86-64 ?= "common-pc-64"
+
+SRCREV_machine_genericx86 ?= "a7d71794e4e38d2f861c1b1dbff761ae0b0836b3"
+SRCREV_machine_genericx86-64 ?= "a7d71794e4e38d2f861c1b1dbff761ae0b0836b3"
+
+COMPATIBLE_MACHINE_genericx86 = "genericx86"
+COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
+
+LINUX_VERSION_genericx86 = "4.8-rc4"
+LINUX_VERSION_genericx86-64 = "4.8-rc4"