aboutsummaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2013-08-27 13:16:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-28 00:25:56 +0100
commit6c3a0292df7ae0cb5bf7d8d19346d7b07610a1a3 (patch)
tree2fd015e6aca0bf8be7466444770099501947255f /meta-yocto-bsp/recipes-kernel
parentda6260f95f4adcca22da9b0d5fb26e93c0a2517f (diff)
downloadopenembedded-core-contrib-6c3a0292df7ae0cb5bf7d8d19346d7b07610a1a3.tar.gz
meta-yocto-bsp: Add genericx86-64 machine
Duplicate the genericx86 machine, but select x86_64 tunables and use the common-pc-64 linux-yocto KMACHINE and config. This has been boot tested with core-image-sato on a Lenovo x220 (Core-i5) and a Supermicro MBD-X8DTL-iF-O (dual-socket Xeon 5680). (From meta-yocto rev: 9b7db7ded0e6b7f5c0cd3ab7fbb0bce4112407da) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Ross Burton <ross.burton@intel.com> Cc: Tom Zanussi <tom.zanussi@intel.com> Cc: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 5756e4c219..c3968ef9cf 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,19 +1,23 @@
KBRANCH_genericx86 = "standard/common-pc/base"
+KBRANCH_genericx86-64 = "standard/common-pc-64/base"
KBRANCH_routerstationpro = "standard/routerstationpro"
KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
KBRANCH_beagleboard = "standard/beagleboard"
KMACHINE_genericx86 ?= "common-pc"
+KMACHINE_genericx86-64 ?= "common-pc-64"
SRCREV_machine_genericx86 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
+SRCREV_machine_genericx86-64 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
SRCREV_machine_routerstationpro ?= "3991d03bd450e9363d5b6e97ede0628ba073db79"
SRCREV_machine_mpc8315e-rdb ?= "8d8339af518104db03f9c36b82f4372569e55b0a"
SRCREV_machine_beagleboard ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
+COMPATIBLE_MACHINE_genericx86 = "genericx86"
+COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
COMPATIBLE_MACHINE_beagleboard = "beagleboard"
-COMPATIBLE_MACHINE_genericx86 = "genericx86"
# routerstationpro has a flash size of 16mb
KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"