aboutsummaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 13:25:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 17:32:15 +0100
commit2000698b17011bbde1c3e5bb01a7d6763316db5a (patch)
tree5080d6d280487d6a8341c18ae56706e5157a0823 /meta-yocto-bsp/recipes-kernel
parent9d6630d1749486e38066650e1de5849c9524adbc (diff)
downloadopenembedded-core-contrib-2000698b17011bbde1c3e5bb01a7d6763316db5a.tar.gz
meta-yocto: Split into distro and bsp components
Now we have settled on best practises and compliance criteria, bring meta-yocto into compliance by separating out the hardware support components into meta-yocto-bsp leaving policy configuration in meta-yocto. Also rename the meta-yocto scripts directory to OE-Core can be a clearly isolated component in poky. (From meta-yocto rev: eac90e27a032ea23d9a4f35c7eef8b1940c80e22) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend25
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend15
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend14
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend15
4 files changed, 69 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 0000000000..274eb822ce
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,25 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# atom-pc support
+COMPATIBLE_MACHINE_atom-pc = "atom-pc"
+KMACHINE_atom-pc = "atom-pc"
+KBRANCH_atom-pc = "yocto/standard/preempt-rt/base"
+SRCREV_machine_pn-linux-yocto-rt_atom-pc = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
+
+# mpc8315e-rdb support
+COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
+KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
+KBRANCH_mpc8315e-rdb = "yocto/standard/preempt-rt/base"
+SRCREV_machine_pn-linux-yocto-rt_mpc8315e-rdb = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
+
+# beagleboard support - 3.0 support has not yet been completed, build failure
+#COMPATIBLE_MACHINE_beagleboard = "beagleboard"
+#KMACHINE_beagleboard = "beagleboard"
+#KBRANCH_beagleboard = "yocto/standard/preempt-rt/base"
+#SRCREV_machine_pn-linux-yocto-rt_beagleboard =
+
+# routerstationpro support - preempt-rt kernel build failure
+COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
+KMACHINE_routerstationpro = "routerstationpro"
+KBRANCH_routerstationpro = "yocto/standard/preempt-rt/routerstationpro"
+SRCREV_machine_pn-linux-yocto-rt_routerstationpro = "634ba79510753eecd27a39a315f690f1c9d46efe"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 0000000000..9641336cf6
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,15 @@
+KBRANCH_atom-pc = "yocto/standard/common-pc/atom-pc"
+KBRANCH_routerstationpro = "yocto/standard/routerstationpro"
+KBRANCH_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb"
+KBRANCH_beagleboard = "yocto/standard/beagleboard"
+
+SRCREV_machine_atom-pc ?= "834c2a69c87ee7211932f8ec5102a472828abcb1"
+SRCREV_machine_routerstationpro ?= "1c17c082b6ee565acc176cde5be835ac4269817b"
+SRCREV_machine_mpc8315e-rdb ?= "f2312437b52dda4499310aacb4c561ba8b8cbeb7"
+SRCREV_machine_beagleboard ?= "3ab688a78cac7b2e32afc83376a53370f2bd13b7"
+
+
+COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
+COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
+COMPATIBLE_MACHINE_beagleboard = "beagleboard"
+COMPATIBLE_MACHINE_atom-pc = "atom-pc"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend
new file mode 100644
index 0000000000..fa160f8caf
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.2.bbappend
@@ -0,0 +1,14 @@
+KBRANCH_atom-pc = "standard/default/common-pc/atom-pc"
+KBRANCH_routerstationpro = "standard/default/routerstationpro"
+KBRANCH_mpc8315e-rdb = "standard/default/fsl-mpc8315e-rdb"
+KBRANCH_beagleboard = "standard/default/beagleboard"
+
+SRCREV_machine_atom-pc ?= "41074a778d251a77e036fd8a99915cd4da6cd8f7"
+SRCREV_machine_routerstationpro ?= "94abc0d75d0a99c40c53402570cd9c569539fee9"
+SRCREV_machine_mpc8315e-rdb ?= "a04e94f4dae9cf6d32d059cf9e0308abe7341a3a"
+SRCREV_machine_beagleboard ?= "40bde7a43ef3cd85729ab02464a7ecdf71e522a6"
+
+COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
+COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
+COMPATIBLE_MACHINE_beagleboard = "beagleboard"
+COMPATIBLE_MACHINE_atom-pc = "atom-pc"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000000..e9a6d9de48
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,15 @@
+KBRANCH_atom-pc = "standard/common-pc/atom-pc"
+KBRANCH_routerstationpro = "standard/routerstationpro"
+KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
+KBRANCH_beagleboard = "standard/beagleboard"
+
+SRCREV_machine_atom-pc ?= "0985844fa6235422c67ef269952fa4e765f252f9"
+SRCREV_machine_routerstationpro ?= "a2907c57acfb8fa71095a3ce5b20994ff859dbc5"
+SRCREV_machine_mpc8315e-rdb ?= "363a6f7e0c95aabec779a7ea3474662d191b935c"
+SRCREV_machine_beagleboard ?= "0985844fa6235422c67ef269952fa4e765f252f9"
+
+
+COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
+COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
+# COMPATIBLE_MACHINE_beagleboard = "beagleboard"
+COMPATIBLE_MACHINE_atom-pc = "atom-pc"