aboutsummaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-02-25 04:42:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-02 22:45:28 +0000
commit0a5ed73408aa948d78f7047c9d9d9c89dafc97fe (patch)
tree615b384a5091f1bb1f8ffbf4a6403de27cd5971b /meta-yocto-bsp/recipes-kernel
parent1a467dc929344f4b2b37b623a9fd85de18cfbdc3 (diff)
downloadopenembedded-core-contrib-0a5ed73408aa948d78f7047c9d9d9c89dafc97fe.tar.gz
meta-yocto/linux-yocto: update qemu BSPs to 3.8 kernel
Change linux-yocto preferred version to 3.8 for the qemu BSPs. The non-qemu default stays at 3.4 until the hardware reference platforms can be validated on the 3.8 kernel. At the same time, we remove the 3.0 linux-yocto bbappends, since they have been removed in the core layers and will cause dangling append problems if left in place. (From meta-yocto rev: 896b845e0e574f4c4f2205e0516c00f178dde185) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend25
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend15
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend14
3 files changed, 14 insertions, 40 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
deleted file mode 100644
index 274eb822ce..0000000000
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
+++ /dev/null
@@ -1,25 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-# atom-pc support
-COMPATIBLE_MACHINE_atom-pc = "atom-pc"
-KMACHINE_atom-pc = "atom-pc"
-KBRANCH_atom-pc = "yocto/standard/preempt-rt/base"
-SRCREV_machine_pn-linux-yocto-rt_atom-pc = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
-
-# mpc8315e-rdb support
-COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
-KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
-KBRANCH_mpc8315e-rdb = "yocto/standard/preempt-rt/base"
-SRCREV_machine_pn-linux-yocto-rt_mpc8315e-rdb = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
-
-# beagleboard support - 3.0 support has not yet been completed, build failure
-#COMPATIBLE_MACHINE_beagleboard = "beagleboard"
-#KMACHINE_beagleboard = "beagleboard"
-#KBRANCH_beagleboard = "yocto/standard/preempt-rt/base"
-#SRCREV_machine_pn-linux-yocto-rt_beagleboard =
-
-# routerstationpro support - preempt-rt kernel build failure
-COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
-KMACHINE_routerstationpro = "routerstationpro"
-KBRANCH_routerstationpro = "yocto/standard/preempt-rt/routerstationpro"
-SRCREV_machine_pn-linux-yocto-rt_routerstationpro = "634ba79510753eecd27a39a315f690f1c9d46efe"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend
deleted file mode 100644
index 9641336cf6..0000000000
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.0.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-KBRANCH_atom-pc = "yocto/standard/common-pc/atom-pc"
-KBRANCH_routerstationpro = "yocto/standard/routerstationpro"
-KBRANCH_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb"
-KBRANCH_beagleboard = "yocto/standard/beagleboard"
-
-SRCREV_machine_atom-pc ?= "834c2a69c87ee7211932f8ec5102a472828abcb1"
-SRCREV_machine_routerstationpro ?= "1c17c082b6ee565acc176cde5be835ac4269817b"
-SRCREV_machine_mpc8315e-rdb ?= "f2312437b52dda4499310aacb4c561ba8b8cbeb7"
-SRCREV_machine_beagleboard ?= "3ab688a78cac7b2e32afc83376a53370f2bd13b7"
-
-
-COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
-COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
-COMPATIBLE_MACHINE_beagleboard = "beagleboard"
-COMPATIBLE_MACHINE_atom-pc = "atom-pc"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 0000000000..479a3860b7
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,14 @@
+KBRANCH_atom-pc = "standard/common-pc/atom-pc"
+KBRANCH_routerstationpro = "standard/routerstationpro"
+KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
+KBRANCH_beagleboard = "standard/beagleboard"
+
+#SRCREV_machine_atom-pc ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
+#SRCREV_machine_routerstationpro ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
+#SRCREV_machine_mpc8315e-rdb ?= "82bb8c34e0eb5e3d3b35d3c5631d9df147b659dd"
+#SRCREV_machine_beagleboard ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
+
+COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
+COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
+COMPATIBLE_MACHINE_beagleboard = "beagleboard"
+COMPATIBLE_MACHINE_atom-pc = "atom-pc"