summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro@enedino.org>2020-04-27 15:33:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-29 15:00:36 +0100
commit06ed491e30b47b8c5f89746e890519dd7de800fd (patch)
tree172732fbc0829e7d313545e3055a2a2241e95605 /meta-skeleton
parentd73aa359e42e707dbc7cfa29c55a2fc8e6bb938a (diff)
downloadopenembedded-core-contrib-06ed491e30b47b8c5f89746e890519dd7de800fd.tar.gz
baremetal-helloworld: Fix IMGDEPLOYDIR expansion
IMGDEPLOYDIR is not being expanded anymore, this causes do_rootfs to fail because it can't create the manifest file, we can set it to the default being set on image.bbclass since this is only a decoy function anyway to satisfy testimage, this makes do_rootfs happy and allows it to continue. Signed-off-by: Alejandro Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Alejandro Hernandez Samaniego <alhe@linux.microsoft.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
index d8633702fc..e84a90f28c 100644
--- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
@@ -37,6 +37,7 @@ do_install(){
# Borrowed from meta-freertos
inherit rootfs-postcommands
inherit deploy
+IMGDEPLOYDIR ?= "${WORKDIR}/deploy-${PN}-image-complete"
do_deploy[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}"
do_rootfs[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}"
DEPLOYDIR = "${IMGDEPLOYDIR}"