aboutsummaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-04-12 14:42:13 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-13 23:50:52 +0100
commitb847f87f4213db917d6760cd399c0afae996cf23 (patch)
treef8f3af7a8ccd9a98ed5ed38c26ab87d0dc25b649 /meta-skeleton
parent1a1927f8a04fe0a2b3b853ebdd33ccb807f00b59 (diff)
downloadopenembedded-core-contrib-b847f87f4213db917d6760cd399c0afae996cf23.tar.gz
hello-mod: Ensure the produced package name begins with kernel-module-
The special key kernel-module- is necessary for the system to avoid a package rename when installing a multilib image. For example: local.conf: IMAGE_INSTALL_append = " hello-mod" bitbake lib32-core-image-minimal The system will translate names and prepend 'lib32-', unless the package begins with kernel-module-. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
index 64a6ddad4c..621f700d4c 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -13,3 +13,11 @@ SRC_URI = "file://Makefile \
"
S = "${WORKDIR}"
+
+# Kernel module packages MUST begin with 'kernel-module-', otherwise
+# multilib image generation can fail.
+#
+# The following line is only necessary if the recipe name does not begin
+# with kernel-module-.
+#
+PKG_${PN} = "kernel-module-${PN}"