aboutsummaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-12-10 17:40:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-14 09:16:32 +0000
commit6f47698e1ef8103cade8b954825848bb8986158c (patch)
tree0628fa1220eb5724c0a5cb6b05c9e7d63722d676 /meta-skeleton
parentc1037a74f934966a0df8c85138b09d672b9f8b36 (diff)
downloadopenembedded-core-contrib-6f47698e1ef8103cade8b954825848bb8986158c.tar.gz
useradd-example: add example for setting clear text password
Use '-P' option for user3 to set a clear text password. This is supposed to serve as an example of how to set clear text password in recipes. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-skeleton/useradd/useradd-example.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
index 53d2340af5..2f8d9b072f 100644
--- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
@@ -32,7 +32,8 @@ USERADD_PACKAGES = "${PN} ${PN}-user3"
USERADD_PARAM_${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2"
# user3 will be managed in the useradd-example-user3 pacakge:
-USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash user3"
+# As an example, we use the -P option to set clear text password for user3
+USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3"
# GROUPADD_PARAM works the same way, which you set to the options
# you'd normally pass to the groupadd command. This will create