aboutsummaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-08-13 11:01:50 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-13 23:03:44 +0100
commit57662d4f813d5795cac1529633db80a09efdb089 (patch)
treed6e751665a23ccc88b7700c60fe2dbf3259524d5 /meta-skeleton
parent23d633cc65cf31486263f120c71df82186cfdd22 (diff)
downloadopenembedded-core-contrib-57662d4f813d5795cac1529633db80a09efdb089.tar.gz
meta-skeleton: Add busybox config fragment example
This shows an example of the config fragment support that both the linux-yocto and busybox recipes use. This example is specific to busybox. By adding busybox CONFIG options into a .cfg file and then adding that .cfg file to SRC_URI the merge_config.sh script will correctly handle these CONFIG options during the do_configure task. The merge_config.sh script uses a last-in wins method. For more details about this, see the Kernel Development Manual Section 2.2.3 http://www.yoctoproject.org/docs/current/kernel-dev/kernel-dev.html#changing-the-configuration Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-core/busybox/busybox/no_rfkill.cfg1
-rw-r--r--meta-skeleton/recipes-core/busybox/busybox_1.21.1.bbappend12
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-core/busybox/busybox/no_rfkill.cfg b/meta-skeleton/recipes-core/busybox/busybox/no_rfkill.cfg
new file mode 100644
index 0000000000..f840ecd26c
--- /dev/null
+++ b/meta-skeleton/recipes-core/busybox/busybox/no_rfkill.cfg
@@ -0,0 +1 @@
+# CONFIG_RFKILL is not set
diff --git a/meta-skeleton/recipes-core/busybox/busybox_1.21.1.bbappend b/meta-skeleton/recipes-core/busybox/busybox_1.21.1.bbappend
new file mode 100644
index 0000000000..64cdefc76d
--- /dev/null
+++ b/meta-skeleton/recipes-core/busybox/busybox_1.21.1.bbappend
@@ -0,0 +1,12 @@
+# Example use of configuration fragments for busybox, which uses the same
+# mechanism as the linux-yocto kernel recipe.
+#
+# The entries here will override any entries in the base busybox recipe
+#
+# More details can be found in the Kernel Dev Manual
+# http://www.yoctoproject.org/docs/current/kernel-dev/kernel-dev.html#changing-the-configuration
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://no_rfkill.cfg \
+ "