summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
diff options
context:
space:
mode:
authorMichael Opdenacker <michael.opdenacker@bootlin.com>2021-07-29 15:34:51 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-30 15:22:01 +0100
commita186c746e431831ccbd459be2175cdaa7ed42a54 (patch)
tree9e8a111db4e6204a9666e58e0c0dd10c4c6c52f3 /meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
parent304eb663e414171d38faeebb3c72e49e6e4e1112 (diff)
downloadopenembedded-core-contrib-a186c746e431831ccbd459be2175cdaa7ed42a54.tar.gz
meta-skeleton: add recipe examples from documentation sources
This adds three examples previously located in the yocto-docs repository (under documentation/ref-manual/examples). The examples were not used for building the documentation so it's better to keep them here where they can automatically be tested. Fixed the "hello-single" to add a version number to the .bb file. After this, all examples build fine with the "master" branch of Poky. Note that the "mtd-utils" example, and example of a recipe for an Autotools page, was not copied over. It doesn't build any more, and anyway, we already have an official recipe for a recent version of "mtd-utils" in OE-core. Signed-off-by: Michael Opdenacker <michael.opdenacker@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c')
-rw-r--r--meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c b/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
new file mode 100644
index 0000000000..fc7169b7b8
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
@@ -0,0 +1,8 @@
+#include <stdio.h>
+
+int main(void)
+{
+ printf("Hello world!\n");
+
+ return 0;
+}