aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorbrian avery <avery.brian@gmail.com>2015-09-21 16:45:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-24 17:52:46 +0100
commit1810d4ab3374d833cb4b68388b456dc7ddb3d685 (patch)
tree2926a2cf3bc8363539ab91615e87598cc8864ea7 /meta-selftest
parentcf3c5a6253e14576a63dde20682ab2cc50bdcbfe (diff)
downloadopenembedded-core-contrib-1810d4ab3374d833cb4b68388b456dc7ddb3d685.tar.gz
meta-selftest: add error recipe and error-image
* The error recipe throws an error during compile * The error-image includes the error recipe * Initial target is toaster selenium testing Signed-off-by: brian avery <avery.brian@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/error/error.bb11
-rw-r--r--meta-selftest/recipes-test/images/error-image.bb8
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/error/error.bb b/meta-selftest/recipes-test/error/error.bb
new file mode 100644
index 0000000000..a7bdecf29d
--- /dev/null
+++ b/meta-selftest/recipes-test/error/error.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Error Test case that fails on do_compile"
+DESCRIPTION = "This generates a compile time error to be used to for testing."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+INHIBIT_DEFAULT_DEPS = "1"
+EXCLUDE_FROM_WORLD = "1"
+
+do_compile() {
+ bbfatal "Failing as expected.";
+}
diff --git a/meta-selftest/recipes-test/images/error-image.bb b/meta-selftest/recipes-test/images/error-image.bb
new file mode 100644
index 0000000000..13d9cc010e
--- /dev/null
+++ b/meta-selftest/recipes-test/images/error-image.bb
@@ -0,0 +1,8 @@
+SUMMARY = "An image that includes the error recipe and will therefore fail"
+DESCRIPTION = "This generates an error. Not currently used by oe-selftest"
+
+IMAGE_INSTALL = "error"
+
+IMAGE_LINGUAS = " "
+
+inherit core-image