summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2016-02-13 11:02:19 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-15 16:28:23 +0000
commit767d814b2e125e20839f204e17512ebe2aec8b95 (patch)
tree632048c51e9b9210c101b8c30a50d98070e1a828 /meta-selftest/recipes-test
parent73e9e3f150bf2de9b27c2ccc73e3dee334ee73fe (diff)
downloadopenembedded-core-contrib-767d814b2e125e20839f204e17512ebe2aec8b95.tar.gz
wic-image-minimal: use uuid for root partition
Used --uuid option to generate PARTUUID for root partion and gpt partition type. As this image is used in runtime testing under qemu it makes sense to ensure that this way of specifying root partition works. Added dependency to gptfdisk-native to wic-image-minimal recipe to be able to create gpt partition table. (From OE-Core rev: ba82867bfda54e86e1de5dc4a6ad7246254cf5c3) Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.bb2
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.wks4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.bb b/meta-selftest/recipes-test/images/wic-image-minimal.bb
index ced22c822a..9c50ddbbf5 100644
--- a/meta-selftest/recipes-test/images/wic-image-minimal.bb
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.bb
@@ -7,7 +7,7 @@ IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}"
IMAGE_FSTYPES = "wic"
RM_OLD_IMAGE = "1"
-DEPENDS = "syslinux syslinux-native parted-native dosfstools-native mtools-native"
+DEPENDS = "syslinux syslinux-native parted-native dosfstools-native mtools-native gptfdisk-native"
# core-image-minimal is referenced in .wks, so we need its rootfs
# to be ready before our rootfs
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.wks b/meta-selftest/recipes-test/images/wic-image-minimal.wks
index 191244bade..d55075d503 100644
--- a/meta-selftest/recipes-test/images/wic-image-minimal.wks
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.wks
@@ -3,8 +3,8 @@
# created from core-image-minimal and wic-image-minimal image recipes.
part /boot --source bootimg-pcbios --ondisk vda --label boot --active --align 1024
-part / --source rootfs --ondisk vda --fstype=ext4 --label platform --align 1024
+part / --source rootfs --ondisk vda --fstype=ext4 --label platform --align 1024 --use-uuid
part /mnt --source rootfs --rootfs-dir=core-image-minimal --ondisk vda --fstype=ext4 --label core --align 1024
part backup --source rootfs --rootfs-dir=wic-image-minimal --ondisk vda --fstype=ext4 --label backup --align 1024
-bootloader --timeout=0 --append="rootwait console=tty0 root=/dev/vda2"
+bootloader --ptable gpt --timeout=0 --append="rootwait console=tty0"