aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-02-24 16:51:30 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:36 +0000
commitd0ae258e963f9bafffc4ca43c87497d27e57c127 (patch)
tree0e385afc038d95ac5b6ce65866c2a4c099a992cb /meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
parent28fea4a104ba85aded2ecfe891e9bf997d72a103 (diff)
downloadopenembedded-core-contrib-d0ae258e963f9bafffc4ca43c87497d27e57c127.tar.gz
oe-selftest: devtool: rework devtool upgrade test
* Use a more real-world test of a recipe pointing to a remote file * The cleanup tracking / teardown commands need to be added towards the top, or they won't have the desired effect of cleaning up if the test fails. * Check that a versioned subdirectory gets renamed to match the new version * Ensure the recipe contents gets changed as we expect it to * Check that the recipe directory is deleted by devtool reset at the end Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb')
-rw-r--r--meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb25
1 files changed, 0 insertions, 25 deletions
diff --git a/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb b/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
deleted file mode 100644
index 33ffc8803a..0000000000
--- a/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-#
-# This file was derived from the 'Hello World!' example recipe in the
-# Yocto Project Development Manual.
-#
-
-DESCRIPTION = "Simple helloworld application used to test the devtool upgrade feature"
-SECTION = "devtool"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-PR = "r0"
-
-SRC_URI = "file://${THISDIR}/files/${P}.tar.gz \
- file://0001-helloword.c-exit-with-EXIT_SUCCESS-instead-of-a-magi.patch \
- "
-
-S = "${WORKDIR}/${P}"
-
-do_compile() {
- ${CC} helloworld.c -o helloworld
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 helloworld ${D}${bindir}
-}