aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-19 15:31:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:16:58 +0100
commit6e9e19230ee731856639f71c5adfb01a92f620d8 (patch)
treee49c91850dddd977630fff4e6469e41aed7d112d /meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
parent4fb6723ab1ee14cf539f0ef2df63a3ee1b978de6 (diff)
downloadopenembedded-core-contrib-6e9e19230ee731856639f71c5adfb01a92f620d8.tar.gz
meta-rt: refresh linux-yocto-rt recipe
Rename the recipe to match the linux-yocto recipe renames using the kernel version in the PV portion of the filename. Add the SRCREVs to the recipe as was done with the core linux-yocto recipes. Add qemux86 as it is also present in the linux-yocto-2.6.34.git repository. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb')
-rw-r--r--meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
deleted file mode 100644
index cba132176a..0000000000
--- a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-inherit kernel
-require recipes-kernel/linux/linux-yocto.inc
-
-KMACHINE_qemux86-64 = "common_pc_64"
-KMACHINE_atom-pc = "atom-pc"
-
-LINUX_VERSION ?= "2.6.34"
-LINUX_KERNEL_TYPE = "preempt_rt"
-LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
-
-KMETA = wrs_meta
-KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
-
-PR = "r1"
-PV = "${LINUX_VERSION}+git${SRCPV}"
-SRCREV_FORMAT = "meta_machine"
-
-COMPATIBLE_MACHINE = "(qemux86-64|atom-pc)"
-
-# this performs a fixup on the SRCREV for new/undefined BSPs
-python __anonymous () {
- import bb, re, string
-
- kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
- bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
-}
-
-SRC_URI = "git://git.yoctoproject.org/linux-2.6-windriver.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
-
-# Functionality flags
-KERNEL_REVISION_CHECKING ?= "t"
-KERNEL_FEATURES=features/netfilter
-
-# extra tasks
-addtask kernel_link_vmlinux after do_compile before do_install
-addtask validate_branches before do_patch after do_kernel_checkout
-
-require recipes-kernel/linux/linux-tools.inc