aboutsummaryrefslogtreecommitdiffstats
path: root/meta-moblin
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2008-11-03 19:11:28 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2008-11-03 19:11:28 +0100
commit7b5d03d08e737dd3637072f60259af5b093b7f70 (patch)
treeaea48a813e03a41ea240443e2669a3a568505783 /meta-moblin
parentb2495018448fb016e91884ff2da8f79a6aec8ca7 (diff)
downloadopenembedded-core-contrib-7b5d03d08e737dd3637072f60259af5b093b7f70.tar.gz
linux-moblin: Add super readahead ext3 specific patch
We need this patch for sreadahead to generate the to be read file list.
Diffstat (limited to 'meta-moblin')
-rw-r--r--meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch65
-rw-r--r--meta-moblin/packages/linux/linux-moblin_2.6.27.bb3
2 files changed, 67 insertions, 1 deletions
diff --git a/meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch b/meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch
new file mode 100644
index 0000000000..101c100dd0
--- /dev/null
+++ b/meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch
@@ -0,0 +1,65 @@
+From: Arjan van de Ven <arjan@linux.intel.com>
+Date: Sun, 21 Sep 2008 11:58:27 -0700
+Subject: [PATCH] superreadahead patch
+
+---
+ fs/ext3/ioctl.c | 3 +++
+ fs/ext3/super.c | 1 +
+ include/linux/ext3_fs.h | 1 +
+ include/linux/fs.h | 2 ++
+ 4 files changed, 7 insertions(+), 0 deletions(-)
+
+diff --git a/fs/ext3/ioctl.c b/fs/ext3/ioctl.c
+index 0d0c701..7e62d7d 100644
+--- a/fs/ext3/ioctl.c
++++ b/fs/ext3/ioctl.c
+@@ -286,6 +286,9 @@ group_add_out:
+ mnt_drop_write(filp->f_path.mnt);
+ return err;
+ }
++ case EXT3_IOC_INODE_JIFFIES: {
++ return inode->created_when;
++ }
+
+
+ default:
+diff --git a/fs/ext3/super.c b/fs/ext3/super.c
+index 2845425..6a896a4 100644
+--- a/fs/ext3/super.c
++++ b/fs/ext3/super.c
+@@ -456,6 +456,7 @@ static struct inode *ext3_alloc_inode(struct super_block *sb)
+ #endif
+ ei->i_block_alloc_info = NULL;
+ ei->vfs_inode.i_version = 1;
++ ei->vfs_inode.created_when = jiffies;
+ return &ei->vfs_inode;
+ }
+
+diff --git a/include/linux/ext3_fs.h b/include/linux/ext3_fs.h
+index 36c5403..b409fa7 100644
+--- a/include/linux/ext3_fs.h
++++ b/include/linux/ext3_fs.h
+@@ -225,6 +225,7 @@ struct ext3_new_group_data {
+ #endif
+ #define EXT3_IOC_GETRSVSZ _IOR('f', 5, long)
+ #define EXT3_IOC_SETRSVSZ _IOW('f', 6, long)
++#define EXT3_IOC_INODE_JIFFIES _IOR('f', 19, long)
+
+ /*
+ * ioctl commands in 32 bit emulation
+diff --git a/include/linux/fs.h b/include/linux/fs.h
+index c6455da..4ac846d 100644
+--- a/include/linux/fs.h
++++ b/include/linux/fs.h
+@@ -655,6 +655,8 @@ struct inode {
+ void *i_security;
+ #endif
+ void *i_private; /* fs or device private pointer */
++
++ unsigned long created_when; /* jiffies of creation time */
+ };
+
+ /*
+--
+1.5.5.1
+
diff --git a/meta-moblin/packages/linux/linux-moblin_2.6.27.bb b/meta-moblin/packages/linux/linux-moblin_2.6.27.bb
index fe26cc555a..b3d990aaa7 100644
--- a/meta-moblin/packages/linux/linux-moblin_2.6.27.bb
+++ b/meta-moblin/packages/linux/linux-moblin_2.6.27.bb
@@ -1,6 +1,6 @@
require linux-moblin.inc
-PR = "r2"
+PR = "r3"
PE = "1"
DEFAULT_PREFERENCE = "-1"
@@ -49,6 +49,7 @@ SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.27.tar.bz2 \
file://0040-fastboot-fix-issues-and-improve-output-of-bootgraph.patch;patch=1 \
file://0041-r8169-8101e.patch;patch=1 \
file://0042-intelfb-945gme.patch;patch=1 \
+ file://0043-superreadahead-patch.patch;patch=1 \
file://defconfig-netbook"
S = "${WORKDIR}/linux-2.6.27"