aboutsummaryrefslogtreecommitdiffstats
path: root/meta-lsb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-13 13:56:49 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-13 13:56:49 +0100
commitbb75c1810454a90a070370fee724da156acb888f (patch)
treeb8ae6e5c6ec1ad15108e20fdd52976ff93705d58 /meta-lsb
parent5abb132fec3e084bcefb4b6197b4806f6b05f515 (diff)
downloadopenembedded-core-contrib-bb75c1810454a90a070370fee724da156acb888f.tar.gz
Move byacc, which, libconvert-asn1-perl and libtimedate-perl to meta-lsb
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-lsb')
-rw-r--r--meta-lsb/packages/byacc/byacc.inc14
-rw-r--r--meta-lsb/packages/byacc/byacc_20100610.bb6
-rw-r--r--meta-lsb/packages/perl/libconvert-asn1-perl_0.21.bb14
-rw-r--r--meta-lsb/packages/perl/libtimedate-perl_1.20.bb21
-rw-r--r--meta-lsb/packages/which/which-2.20/remove-declaration.patch16
-rw-r--r--meta-lsb/packages/which/which_2.20.bb35
6 files changed, 106 insertions, 0 deletions
diff --git a/meta-lsb/packages/byacc/byacc.inc b/meta-lsb/packages/byacc/byacc.inc
new file mode 100644
index 0000000000..c6a5e38f77
--- /dev/null
+++ b/meta-lsb/packages/byacc/byacc.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "Berkeley Yacc"
+SECTION = "devel"
+LICENSE = "public domain"
+
+SRC_URI = "ftp://invisible-island.net/byacc/byacc-${PV}.tgz"
+EXTRA_OECONF += "--program-transform-name='s,^,b,'"
+
+BBCLASSEXTEND = "native"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
diff --git a/meta-lsb/packages/byacc/byacc_20100610.bb b/meta-lsb/packages/byacc/byacc_20100610.bb
new file mode 100644
index 0000000000..48d0e4e425
--- /dev/null
+++ b/meta-lsb/packages/byacc/byacc_20100610.bb
@@ -0,0 +1,6 @@
+PR = "r0"
+
+require byacc.inc
+
+SRC_URI[md5sum] = "b9715b9a2867c221176b597e8f73cbc9"
+SRC_URI[sha256sum] = "1364c7fe382de659e8b9841a1736b645345a460d2f4302303e80c02235a2a575"
diff --git a/meta-lsb/packages/perl/libconvert-asn1-perl_0.21.bb b/meta-lsb/packages/perl/libconvert-asn1-perl_0.21.bb
new file mode 100644
index 0000000000..3292ee338f
--- /dev/null
+++ b/meta-lsb/packages/perl/libconvert-asn1-perl_0.21.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Convert::ASN1 - ASN.1 Encode/Decode library"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/Convert-ASN1-${PV}.tar.gz"
+
+S = "${WORKDIR}/Convert-ASN1-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
+
+PACKAGE_ARCH = "all"
diff --git a/meta-lsb/packages/perl/libtimedate-perl_1.20.bb b/meta-lsb/packages/perl/libtimedate-perl_1.20.bb
new file mode 100644
index 0000000000..84406adfb0
--- /dev/null
+++ b/meta-lsb/packages/perl/libtimedate-perl_1.20.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "TimeDate - parser for absolute times"
+SECTION = "libs"
+# You can redistribute it and/or modify it under the same terms as Perl itself.
+LICENSE = "Artistic|GPL"
+PR = "r2"
+
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/TimeDate-${PV}.tar.gz"
+
+S = "${WORKDIR}/TimeDate-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
+
+RDEPENDS_${PN}_virtclass-native = ""
+RDEPENDS_${PN} += "perl-module-carp perl-module-exporter perl-module-strict perl-module-time-local"
+PACKAGE_ARCH = "all"
+
+SRC_URI[md5sum] = "7da7452bce4c684e4238e6d09b390200"
+SRC_URI[sha256sum] = "f8251a791f6692c69952b4af697c01df93981ad1ab133279d034656a03cd3755"
diff --git a/meta-lsb/packages/which/which-2.20/remove-declaration.patch b/meta-lsb/packages/which/which-2.20/remove-declaration.patch
new file mode 100644
index 0000000000..09b81439b6
--- /dev/null
+++ b/meta-lsb/packages/which/which-2.20/remove-declaration.patch
@@ -0,0 +1,16 @@
+Remove the declaration of group_member since it has already been
+declared in unistd.h
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN which-2.20-orig/bash.c which-2.20/bash.c
+--- which-2.20-orig/bash.c 2010-08-03 12:59:08.897088878 +0800
++++ which-2.20/bash.c 2010-08-03 13:17:23.406097212 +0800
+@@ -46,7 +46,6 @@
+ * - changed all occurences of 'gid_t' into 'GID_T'.
+ * - exported functions needed in which.c
+ */
+-static int group_member (GID_T gid);
+ static char* extract_colon_unit (char const* string, int* p_index);
+
+ /*===========================================================================
diff --git a/meta-lsb/packages/which/which_2.20.bb b/meta-lsb/packages/which/which_2.20.bb
new file mode 100644
index 0000000000..b7730de3b3
--- /dev/null
+++ b/meta-lsb/packages/which/which_2.20.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "which - shows the full path of (shell) commands."
+SECTION = "libs"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
+ file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2"
+HOMEPAGE = "http://ftp.gnu.org/gnu/which/"
+DEPENDS = "cwautomacros-native"
+
+inherit autotools
+
+PR = "r0"
+
+SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \
+ file://remove-declaration.patch"
+
+do_configure_prepend() {
+ sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am
+}
+
+do_install() {
+ autotools_do_install
+ mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
+}
+
+pkg_postinst_${PN} () {
+ if [ "${PN}" = "${BPN}" ] ; then
+ update-alternatives --install ${bindir}/which which which.${PN} 100
+ fi
+}
+
+pkg_prerm_${PN} () {
+ if [ "${PN}" = "${BPN}" ] ; then
+ update-alternatives --remove which which.${PN}
+ fi
+}