aboutsummaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-01-30 22:52:51 +0000
committerRichard Purdie <richard@openedhand.com>2007-01-30 22:52:51 +0000
commit52c2e1a00f220905c4b28347c15daac3df5881b2 (patch)
treef5a754176d30bcea095ad5d84b58dc763a478a77 /meta-extras
parent81f0ee53d5c1bbb33c256c909bb5b7b16dcf8f7c (diff)
downloadopenembedded-core-contrib-52c2e1a00f220905c4b28347c15daac3df5881b2.tar.gz
Add syslog-ng to poky-extras
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1235 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/syslog-ng/files/initscript45
-rw-r--r--meta-extras/packages/syslog-ng/files/syslog-ng.conf89
-rw-r--r--meta-extras/packages/syslog-ng/syslog-ng_1.6.8.bb30
3 files changed, 164 insertions, 0 deletions
diff --git a/meta-extras/packages/syslog-ng/files/initscript b/meta-extras/packages/syslog-ng/files/initscript
new file mode 100644
index 0000000000..b95e8adc20
--- /dev/null
+++ b/meta-extras/packages/syslog-ng/files/initscript
@@ -0,0 +1,45 @@
+#! /bin/sh
+#
+# This is an init script for openembedded
+# Copy it to /etc/init.d/syslog-ng and type
+# > update-rc.d syslog-ng defaults 5
+#
+
+
+syslog_ng=/usr/sbin/syslog-ng
+test -x "$syslog_ng" || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting syslog-ng:"
+ start-stop-daemon --start --quiet --exec $syslog_ng
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping syslog-ng:"
+ start-stop-daemon --stop --quiet --pidfile /var/run/syslog-ng.pid
+ echo "."
+ ;;
+ reload|force-reload)
+ start-stop-daemon --stop --quiet --signal 1 --exec $syslog_ng
+ ;;
+ restart)
+ echo "Stopping syslog-ng:"
+ start-stop-daemon --stop --quiet --pidfile /var/run/syslog-ng.pid
+ echo -n "Waiting for syslog-ng to die off"
+ for i in 1 2 3 ;
+ do
+ sleep 1
+ echo -n "."
+ done
+ echo ""
+ echo -n "Starting syslog-ng:"
+ start-stop-daemon --start --quiet --exec $syslog_ng
+ echo "."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/syslog-ng {start|stop|reload|restart|force-reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/meta-extras/packages/syslog-ng/files/syslog-ng.conf b/meta-extras/packages/syslog-ng/files/syslog-ng.conf
new file mode 100644
index 0000000000..4d1e9f8b22
--- /dev/null
+++ b/meta-extras/packages/syslog-ng/files/syslog-ng.conf
@@ -0,0 +1,89 @@
+#
+# Syslog-ng example configuration for for Debian GNU/Linux
+#
+# Copyright (c) 1999 anonymous
+# Copyright (c) 1999 Balazs Scheidler
+# $Id: syslog-ng.conf.sample,v 1.3 2003/05/20 08:57:27 asd Exp $
+#
+# Syslog-ng configuration file, compatible with default Debian syslogd
+# installation.
+#
+
+options { long_hostnames(off); sync(0); };
+
+source src { file("/proc/kmsg"); unix-stream("/dev/log"); internal(); };
+source net { udp(); };
+
+destination authlog { file("/var/log/auth.log"); };
+destination syslog { file("/var/log/syslog"); };
+destination cron { file("/var/log/cron.log"); };
+destination daemon { file("/var/log/daemon.log"); };
+destination kern { file("/var/log/kern.log"); };
+destination lpr { file("/var/log/lpr.log"); };
+destination user { file("/var/log/user.log"); };
+destination uucp { file("/var/log/uucp.log"); };
+destination ppp { file("/var/log/ppp.log"); };
+destination mail { file("/var/log/mail.log"); };
+
+destination mailinfo { file("/var/log/mail.info"); };
+destination mailwarn { file("/var/log/mail.warn"); };
+destination mailerr { file("/var/log/mail.err"); };
+
+destination newscrit { file("/var/log/news/news.crit"); };
+destination newserr { file("/var/log/news/news.err"); };
+destination newsnotice { file("/var/log/news/news.notice"); };
+
+destination debug { file("/var/log/debug"); };
+destination messages { file("/var/log/messages"); };
+destination console { usertty("root"); };
+destination console_all { file("/dev/tty12"); };
+#destination loghost { udp("loghost" port(999)); };
+
+
+destination xconsole { pipe("/dev/xconsole"); };
+
+filter f_auth { facility(auth); };
+filter f_authpriv { facility(auth, authpriv); };
+filter f_syslog { not facility(authpriv, mail); };
+filter f_cron { facility(cron); };
+filter f_daemon { facility(daemon); };
+filter f_kern { facility(kern); };
+filter f_lpr { facility(lpr); };
+filter f_mail { facility(mail); };
+filter f_user { facility(user); };
+filter f_uucp { facility(cron); };
+filter f_ppp { facility(local2); };
+filter f_news { facility(news); };
+filter f_debug { not facility(auth, authpriv, news, mail); };
+filter f_messages { level(info..warn)
+ and not facility(auth, authpriv, mail, news); };
+filter f_emergency { level(emerg); };
+
+filter f_info { level(info); };
+filter f_notice { level(notice); };
+filter f_warn { level(warn); };
+filter f_crit { level(crit); };
+filter f_err { level(err); };
+
+log { source(src); filter(f_authpriv); destination(authlog); };
+log { source(src); filter(f_syslog); destination(syslog); };
+log { source(src); filter(f_cron); destination(cron); };
+log { source(src); filter(f_daemon); destination(daemon); };
+log { source(src); filter(f_kern); destination(kern); };
+log { source(src); filter(f_lpr); destination(lpr); };
+log { source(src); filter(f_mail); destination(mail); };
+log { source(src); filter(f_user); destination(user); };
+log { source(src); filter(f_uucp); destination(uucp); };
+log { source(src); filter(f_mail); filter(f_info); destination(mailinfo); };
+log { source(src); filter(f_mail); filter(f_warn); destination(mailwarn); };
+log { source(src); filter(f_mail); filter(f_err); destination(mailerr); };
+log { source(src); filter(f_news); filter(f_crit); destination(newscrit); };
+log { source(src); filter(f_news); filter(f_err); destination(newserr); };
+log { source(src); filter(f_news); filter(f_notice); destination(newsnotice); };
+log { source(src); filter(f_debug); destination(debug); };
+log { source(src); filter(f_messages); destination(messages); };
+log { source(src); filter(f_emergency); destination(console); };
+log { source(src); filter(f_ppp); destination(ppp); };
+log { source(src); destination(console_all); };
+
+
diff --git a/meta-extras/packages/syslog-ng/syslog-ng_1.6.8.bb b/meta-extras/packages/syslog-ng/syslog-ng_1.6.8.bb
new file mode 100644
index 0000000000..af7a9b4502
--- /dev/null
+++ b/meta-extras/packages/syslog-ng/syslog-ng_1.6.8.bb
@@ -0,0 +1,30 @@
+PR = "r9"
+DESCRIPTION = "Alternative system logger daemon"
+DEPENDS = "libol flex"
+
+SRC_URI = "http://www.balabit.com/downloads/syslog-ng/1.6/src/${PN}-${PV}.tar.gz \
+ file://syslog-ng.conf \
+ file://initscript"
+
+S = "${WORKDIR}/${PN}-${PV}"
+inherit autotools update-rc.d
+
+EXTRA_OECONF = "--with-libol=${STAGING_BINDIR}/"
+CONFFILES_${PN} = "${sysconfdir}/${PN}/syslog-ng.conf"
+INITSCRIPT_NAME = "syslog-ng"
+INITSCRIPT_PARAMS = "defaults 05"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/${PN}
+ install ${WORKDIR}/syslog-ng.conf ${D}${sysconfdir}/${PN}/syslog-ng.conf
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/initscript ${D}/${sysconfdir}/init.d/syslog-ng
+}
+
+pkg_postinst() {
+ update-rc.d -f syslog remove
+}
+
+pkg_postrm() {
+ update-rc.d syslog add 5
+}