aboutsummaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-graphics/psb-kernel-source/psb-kernel-source_4.42.0.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-20 12:24:36 -0600
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-23 14:20:50 +0000
commiteca21e63590c165c5aaf14cbd51c7f325b731aba (patch)
treee04b863b4a355e46a6ce526caf6dcc98713eb620 /meta-emenlow/recipes-graphics/psb-kernel-source/psb-kernel-source_4.42.0.bb
parentab83f5f266ee7f66d14e3711ec84907750ea7e91 (diff)
downloadopenembedded-core-contrib-eca21e63590c165c5aaf14cbd51c7f325b731aba.tar.gz
meta-emenlow: update to the new BSP layout
This modifies the meta-emenlow BSP layer to reflect the new BSP standard layout as defined in the latestYocto BSP Developer's Guide. There's no change in functionality here - this simply moves things around, adds a README, and makes the SRCREVs local. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-graphics/psb-kernel-source/psb-kernel-source_4.42.0.bb')
-rw-r--r--meta-emenlow/recipes-graphics/psb-kernel-source/psb-kernel-source_4.42.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/psb-kernel-source/psb-kernel-source_4.42.0.bb b/meta-emenlow/recipes-graphics/psb-kernel-source/psb-kernel-source_4.42.0.bb
new file mode 100644
index 0000000000..5c1a3e1c27
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/psb-kernel-source/psb-kernel-source_4.42.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Kernel module for the Poulsbo (psb) 2D X11 driver"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://GPLv2_License.txt;md5=f5ca3155cfeaa64a6ea228b11ad6916d"
+PR = "r1"
+
+inherit module
+
+SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/psb-kernel-source_4.42.0-0ubuntu2~1004um2.tar.gz \
+ file://build.patch;patch=1"
+
+do_compile () {
+ oe_runmake LINUXDIR=${STAGING_KERNEL_DIR} DRM_MODULES="psb"
+}
+
+do_install () {
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/extra
+ cp ${WORKDIR}/${PN}-${PV}/*.ko ${D}/lib/modules/${KERNEL_VERSION}/extra
+}
+
+FILES_${PN} += "${base_libdir}/modules/${KERNEL_VERSION}/extra/*.ko"
+
+DEPENDS += "virtual/kernel"
+
+COMPATIBLE_MACHINE = "emenlow"