aboutsummaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-graphics/psb-firmware/psb-firmware_0.30.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-20 12:24:36 -0600
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-23 14:20:50 +0000
commiteca21e63590c165c5aaf14cbd51c7f325b731aba (patch)
treee04b863b4a355e46a6ce526caf6dcc98713eb620 /meta-emenlow/recipes-graphics/psb-firmware/psb-firmware_0.30.bb
parentab83f5f266ee7f66d14e3711ec84907750ea7e91 (diff)
downloadopenembedded-core-contrib-eca21e63590c165c5aaf14cbd51c7f325b731aba.tar.gz
meta-emenlow: update to the new BSP layout
This modifies the meta-emenlow BSP layer to reflect the new BSP standard layout as defined in the latestYocto BSP Developer's Guide. There's no change in functionality here - this simply moves things around, adds a README, and makes the SRCREVs local. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-graphics/psb-firmware/psb-firmware_0.30.bb')
-rw-r--r--meta-emenlow/recipes-graphics/psb-firmware/psb-firmware_0.30.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/psb-firmware/psb-firmware_0.30.bb b/meta-emenlow/recipes-graphics/psb-firmware/psb-firmware_0.30.bb
new file mode 100644
index 0000000000..164ea66c82
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/psb-firmware/psb-firmware_0.30.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Binary firmware for the Poulsbo (psb) 3D X11 driver"
+LICENSE = "Intel-binary-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=02c597a2f082b4581596065bb5a521a8"
+PR = "r0"
+
+SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/psb-firmware_0.30-0ubuntu1netbook1ubuntu1.tar.gz"
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware/
+ install -m 0644 ${WORKDIR}/psb-firmware-0.30/msvdx_fw.bin ${D}${base_libdir}/firmware/
+}
+
+FILES_${PN} += "${base_libdir}/firmware/msvdx_fw.bin"
+
+COMPATIBLE_MACHINE = "emenlow"