summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-20 12:24:36 -0600
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-23 14:20:50 +0000
commiteca21e63590c165c5aaf14cbd51c7f325b731aba (patch)
treee04b863b4a355e46a6ce526caf6dcc98713eb620 /meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
parentab83f5f266ee7f66d14e3711ec84907750ea7e91 (diff)
downloadopenembedded-core-contrib-eca21e63590c165c5aaf14cbd51c7f325b731aba.tar.gz
meta-emenlow: update to the new BSP layout
This modifies the meta-emenlow BSP layer to reflect the new BSP standard layout as defined in the latestYocto BSP Developer's Guide. There's no change in functionality here - this simply moves things around, adds a README, and makes the SRCREVs local. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch')
-rw-r--r--meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
new file mode 100644
index 0000000000..14bde6887a
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
@@ -0,0 +1,61 @@
+# Make this package produce libdrm-poulsbo instead of libdrm so that the
+# emenlow libdrm can coexist with the normal libdrm.
+# jdike@linux.intel.com
+
+Index: libdrm-poulsbo-2.3.0/configure.ac
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/configure.ac
++++ libdrm-poulsbo-2.3.0/configure.ac
+@@ -19,7 +19,7 @@
+ # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+ AC_PREREQ(2.57)
+-AC_INIT([libdrm], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm)
++AC_INIT([libdrm_poulsbo], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm_poulsbo)
+ AC_CONFIG_SRCDIR([Makefile.am])
+ AM_INIT_AUTOMAKE([dist-bzip2])
+
+@@ -35,4 +35,4 @@ AC_SYS_LARGEFILE
+ pkgconfigdir=${libdir}/pkgconfig
+ AC_SUBST(pkgconfigdir)
+
+-AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm.pc])
++AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm_poulsbo.pc])
+Index: libdrm-poulsbo-2.3.0/Makefile.am
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/Makefile.am
++++ libdrm-poulsbo-2.3.0/Makefile.am
+@@ -25,6 +25,6 @@ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = libdrm shared-core
+
+ pkgconfigdir = @pkgconfigdir@
+-pkgconfig_DATA = libdrm.pc
++pkgconfig_DATA = libdrm_poulsbo.pc
+
+-EXTRA_DIST = libdrm.pc.in
++EXTRA_DIST = libdrm_poulsbo.pc.in
+Index: libdrm-poulsbo-2.3.0/libdrm/Makefile.am
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/libdrm/Makefile.am
++++ libdrm-poulsbo-2.3.0/libdrm/Makefile.am
+@@ -18,14 +18,14 @@
+ # IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+ # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-libdrm_la_LTLIBRARIES = libdrm.la
+-libdrm_ladir = $(libdir)
+-libdrm_la_LDFLAGS = -version-number 2:3:0 -no-undefined
++libdrm_poulsbo_la_LTLIBRARIES = libdrm_poulsbo.la
++libdrm_poulsbo_ladir = $(libdir)
++libdrm_poulsbo_la_LDFLAGS = -version-number 2:3:0 -no-undefined
+
+ AM_CFLAGS = -I$(top_srcdir)/shared-core
+-libdrm_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c xf86drmMode.c
++libdrm_poulsbo_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c xf86drmMode.c
+
+-libdrmincludedir = ${includedir}/psb
+-libdrminclude_HEADERS = xf86drm.h xf86mm.h xf86drmMode.h
++libdrm_poulsboincludedir = ${includedir}/psb
++libdrm_poulsboinclude_HEADERS = xf86drm.h xf86mm.h xf86drmMode.h
+
+ EXTRA_DIST = ChangeLog TODO