aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-sato/epdfview/epdfview_0.1.6.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-sato/epdfview/epdfview_0.1.6.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadopenembedded-core-contrib-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-sato/epdfview/epdfview_0.1.6.bb')
-rw-r--r--meta-demoapps/recipes-sato/epdfview/epdfview_0.1.6.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-sato/epdfview/epdfview_0.1.6.bb b/meta-demoapps/recipes-sato/epdfview/epdfview_0.1.6.bb
new file mode 100644
index 0000000000..a528474d9b
--- /dev/null
+++ b/meta-demoapps/recipes-sato/epdfview/epdfview_0.1.6.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A minimal PDF viewer based on gtk and poppler"
+HOMEPAGE = "http://trac.emma-soft.com/epdfview/"
+LICENSE = "GPLv2"
+SECTION = "x11/applications"
+DEPENDS = "poppler gtk+ libowl"
+PR="r0"
+
+SRC_URI = "http://trac.emma-soft.com/epdfview/chrome/site/releases/epdfview-${PV}.tar.bz2 \
+ file://owl-menus.patch \
+ file://epdfview.desktop \
+ file://epdfview-ui.xml \
+ file://epdfview-ui-print.xml"
+
+inherit autotools gettext
+
+do_install_prepend() {
+ install ${WORKDIR}/epdfview-ui.xml ${S}/data/epdfview-ui.xml
+ install ${WORKDIR}/epdfview-ui-print.xml ${S}/data/epdfview-ui-print.xml
+ install ${WORKDIR}/epdfview.desktop ${S}/data/epdfview.desktop
+}
+