aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadopenembedded-core-contrib-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb')
-rw-r--r--meta-demoapps/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb b/meta-demoapps/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb
new file mode 100644
index 0000000000..ff49418540
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Telepathy Jabber/XMPP connection manager"
+DESCRIPTION = "Telepathy implementation of the Jabber/XMPP protocols."
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus loudmouth telepathy-glib dbus-glib"
+LICENSE = "LGPL"
+
+# gabble.manager needs to get regenerated every release, so please don't copy it over blindly
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-gabble/${P}.tar.gz \
+ file://gabble.manager"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ cp ${WORKDIR}/gabble.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"