aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadopenembedded-core-contrib-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb')
-rw-r--r--meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb b/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
new file mode 100644
index 0000000000..022f709f99
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/openswan/openswan_2.4.7.bb
@@ -0,0 +1,37 @@
+SECTION = "console/network"
+SUMMARY = "IPsec implementation"
+DESCRIPTION = "Openswan is an Open Source implementation of IPsec for the \
+Linux operating system."
+HOMEPAGE = "http://www.openswan.org"
+LICENSE = "GPLv2"
+DEPENDS = "gmp flex-native"
+RRECOMMENDS = "kernel-module-ipsec"
+RDEPENDS_nylon = "perl"
+PR = "r0"
+
+SRC_URI = "http://www.openswan.org/download/old/openswan-${PV}.tar.gz \
+ file://openswan-2.4.7-gentoo.patch;patch=1 \
+ file://installflags.patch;patch=1 \
+ file://ld-library-path-breakage.patch;patch=1"
+S = "${WORKDIR}/openswan-${PV}"
+
+PARALLEL_MAKE = ""
+EXTRA_OEMAKE = "DESTDIR=${D} \
+ USERCOMPILE="${CFLAGS}" \
+ FINALCONFDIR=${sysconfdir}/ipsec \
+ INC_RCDEFAULT=${sysconfdir}/init.d \
+ INC_USRLOCAL=${prefix} \
+ INC_MANDIR=share/man WERROR=''"
+
+do_compile () {
+ oe_runmake programs
+}
+
+do_install () {
+ oe_runmake install
+}
+
+FILES_${PN} = "${sysconfdir} ${libdir}/ipsec/* ${sbindir}/* ${libexecdir}/ipsec/*"
+FILES_${PN}-dbg += "${libdir}/ipsec/.debug ${libexecdir}/ipsec/.debug"
+
+CONFFILES_${PN} = "${sysconfdir}/ipsec/ipsec.conf"