summaryrefslogtreecommitdiffstats
path: root/lib/toaster/bldcontrol/localhostbecontroller.py
diff options
context:
space:
mode:
authorMichael Wood <michael.g.wood@intel.com>2015-12-14 18:45:02 +0000
committerMichael Wood <michael.g.wood@intel.com>2016-02-08 17:35:47 +0000
commite6a7cacbddd1df5bac0b79384199cf7264c5bbd5 (patch)
tree4c557862bfb67000fda9f37f343cba07875f780f /lib/toaster/bldcontrol/localhostbecontroller.py
parent5ddb35c98b609d85f97d482b54cabe3a2812afe6 (diff)
downloadopenembedded-core-contrib-e6a7cacbddd1df5bac0b79384199cf7264c5bbd5.tar.gz
toaster: localhostbectrl Update the dirpath of customrecipe's base layer
We need to know the location of the based_on recipe's layer on the file system before we try and generate the custom image recipe. As we read the recipe to make the custom version. Signed-off-by: Michael Wood <michael.g.wood@intel.com> Signed-off-by: brian avery <avery.brian@gmail.com>
Diffstat (limited to 'lib/toaster/bldcontrol/localhostbecontroller.py')
-rw-r--r--lib/toaster/bldcontrol/localhostbecontroller.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/lib/toaster/bldcontrol/localhostbecontroller.py b/lib/toaster/bldcontrol/localhostbecontroller.py
index 8acf013476..a7db1efc65 100644
--- a/lib/toaster/bldcontrol/localhostbecontroller.py
+++ b/lib/toaster/bldcontrol/localhostbecontroller.py
@@ -239,6 +239,25 @@ class LocalhostBEController(BuildEnvironmentController):
with open(config, "w") as conf:
conf.write('BBPATH .= ":${LAYERDIR}"\nBBFILES += "${LAYERDIR}/recipes/*.bb"\n')
+ # Update the Layer_Version dirpath that has our base_recipe in
+ # to be able to read the base recipe to then generate the
+ # custom recipe.
+ br_layer_base_recipe = layers.get(
+ layer_version=customrecipe.base_recipe.layer_version)
+
+ br_layer_base_dirpath = \
+ os.path.join(self.be.sourcedir,
+ self.getGitCloneDirectory(
+ br_layer_base_recipe.giturl,
+ br_layer_base_recipe.commit),
+ customrecipe.base_recipe.layer_version.dirpath
+ )
+
+ customrecipe.base_recipe.layer_version.dirpath = \
+ br_layer_base_dirpath
+
+ customrecipe.base_recipe.layer_version.save()
+
# create recipe
recipe_path = \
os.path.join(layerpath, "recipes", "%s.bb" % target.target)