aboutsummaryrefslogtreecommitdiffstats
path: root/handbook
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-06-04 14:48:34 +0100
committerJoshua Lock <josh@linux.intel.com>2010-06-04 20:02:06 +0100
commit1ccbc1549ec509d737dc39a9440aae1650bde1ad (patch)
treea8f16a01b1e3a52bac7f0991f806855291fe4b1d /handbook
parentf5d0471541ddc29f11c2f17075fd8d46adea740d (diff)
downloadopenembedded-core-contrib-1ccbc1549ec509d737dc39a9440aae1650bde1ad.tar.gz
handbook: use XML catalogues to make building work on all(?) distros
Thanks to Damien's pointers we should now be able to generate the handbook regardless of host distro Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'handbook')
-rw-r--r--handbook/Makefile12
-rw-r--r--handbook/poky-doc-tools/Makefile.am8
-rwxr-xr-xhandbook/poky-doc-tools/autogen.sh2
-rw-r--r--handbook/poky-doc-tools/common/poky-db-pdf.xsl2
-rw-r--r--handbook/poky-doc-tools/poky-docbook-to-pdf.in7
5 files changed, 23 insertions, 8 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
index 01353b11af..5dff1a8742 100644
--- a/handbook/Makefile
+++ b/handbook/Makefile
@@ -1,7 +1,6 @@
all: html pdf tarball
pdf:
-
./poky-doc-tools/poky-docbook-to-pdf poky-handbook.xml
./poky-doc-tools/poky-docbook-to-pdf bsp-guide.xml
# -- old way --
@@ -11,12 +10,17 @@ XSLTOPTS = --stringparam html.stylesheet style.css \
--stringparam chapter.autolabel 1 \
--stringparam appendix.autolabel 1 \
--stringparam section.autolabel 1
-XSLTOPTS2 = --xinclude /usr/share/xml/docbook/stylesheet/nwalsh/html/docbook.xsl
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
- xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSLTOPTS2) poky-handbook.xml
- xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSLTOPTS2) bsp-guide.xml
+ xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSL_XHTML_URI) poky-handbook.xml
+ xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
# -- old way --
# xmlto xhtml-nochunks poky-handbook.xml
diff --git a/handbook/poky-doc-tools/Makefile.am b/handbook/poky-doc-tools/Makefile.am
index ca92ae714c..4533cd832d 100644
--- a/handbook/poky-doc-tools/Makefile.am
+++ b/handbook/poky-doc-tools/Makefile.am
@@ -7,7 +7,13 @@ bin_SCRIPTS = poky-docbook-to-pdf
edit = sed \
-e 's,@datadir\@,$(pkgdatadir),g' \
-e 's,@prefix\@,$(prefix),g' \
- -e 's,@version\@,@VERSION@,g'
+ -e 's,@version\@,@VERSION@,g'
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI="http://docbook.sourceforge.net/release/xsl/current"
+XSL_TEMPLATE_URI = $(XSL_BASE_URI)/template/titlepage.xsl
poky-docbook-to-pdf: poky-docbook-to-pdf.in
rm -f poky-docbook-to-pdf
diff --git a/handbook/poky-doc-tools/autogen.sh b/handbook/poky-doc-tools/autogen.sh
index 5daa935608..d68a142b83 100755
--- a/handbook/poky-doc-tools/autogen.sh
+++ b/handbook/poky-doc-tools/autogen.sh
@@ -1,3 +1,3 @@
#! /bin/sh
autoreconf -v --install || exit 1
-./configure --enable-maintainer-mode --enable-debug "$@"
+./configure "$@"
diff --git a/handbook/poky-doc-tools/common/poky-db-pdf.xsl b/handbook/poky-doc-tools/common/poky-db-pdf.xsl
index 302e66f640..3dd065a57e 100644
--- a/handbook/poky-doc-tools/common/poky-db-pdf.xsl
+++ b/handbook/poky-doc-tools/common/poky-db-pdf.xsl
@@ -1,7 +1,7 @@
<?xml version='1.0'?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns="http://www.w3.org/1999/xhtml" xmlns:fo="http://www.w3.org/1999/XSL/Format" version="1.0">
- <xsl:import href="file:///usr/share/xml/docbook/stylesheet/nwalsh/fo/docbook.xsl"/>
+ <xsl:import href="http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl" />
<!-- check project-plan.sh for how this is generated, needed to tweak
the cover page
diff --git a/handbook/poky-doc-tools/poky-docbook-to-pdf.in b/handbook/poky-doc-tools/poky-docbook-to-pdf.in
index cc999ab995..b56aee4954 100644
--- a/handbook/poky-doc-tools/poky-docbook-to-pdf.in
+++ b/handbook/poky-doc-tools/poky-docbook-to-pdf.in
@@ -18,9 +18,14 @@ BASENAME=`basename $1 .xml` || exit 1
FO="$BASENAME.fo"
PDF="$BASENAME.pdf"
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI="http://docbook.sourceforge.net/release/xsl/current"
+
xsltproc -o /tmp/titlepage.xsl \
--xinclude \
- /usr/share/xml/docbook/stylesheet/nwalsh/template/titlepage.xsl \
+ $XSL_BASE_URI/template/titlepage.xsl \
@datadir@/common/titlepage.templates.xml || exit 1
xsltproc --xinclude \