aboutsummaryrefslogtreecommitdiffstats
path: root/documentation
diff options
context:
space:
mode:
authorScott Rifenbark <srifenbark@gmail.com>2016-09-14 06:01:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-23 15:27:34 +0100
commit7d208c1c77dbf079b66a28076174a08951b27549 (patch)
tree658e17c34f36103aab86c192140f527b455bd8b9 /documentation
parentaba386b92cb1bd926a69f703587b133363374dee (diff)
downloadopenembedded-core-contrib-7d208c1c77dbf079b66a28076174a08951b27549.tar.gz
ref-manual: Applied review edits to auto added runtime deps
Fixes [YOCTO #10248] Applied some review changes. Minor wording tweaks and typo fixes. (From yocto-docs rev: a9e99c8b44c48c74448487187cebfe8df331e9e1) Signed-off-by: Scott Rifenbark <srifenbark@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation')
-rw-r--r--documentation/ref-manual/ref-variables.xml11
-rw-r--r--documentation/ref-manual/technical-details.xml20
2 files changed, 16 insertions, 15 deletions
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index a10a0dca75..a97369dfad 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -10493,10 +10493,9 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
the
<link linkend='ref-tasks-package_write_deb'><filename>do_package_write_*</filename></link>
tasks.
- Exactly how this is done depends on the package format used
- as described in the
- <link linkend='var-PACKAGE_CLASSES'><filename>PACKAGE_CLASSES</filename></link>
- variable.
+ Exactly how this is done depends on which package format
+ is used, which is determined by
+ <link linkend='var-PACKAGE_CLASSES'><filename>PACKAGE_CLASSES</filename></link>.
When the corresponding package manager installs the
package, it will know to also install the packages on
which it depends.
@@ -10509,9 +10508,9 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
dependency to be added.
This dependency is from the recipe's
<link linkend='ref-tasks-build'><filename>do_build</filename></link>
- (not to be confused with the
+ (not to be confused with
<link linkend='ref-tasks-compile'><filename>do_compile</filename></link>)
- task to the to the <filename>do_package_write_*</filename>
+ task to the <filename>do_package_write_*</filename>
task of the recipes that build <filename>bar</filename> and
<filename>baz</filename>.
</para>
diff --git a/documentation/ref-manual/technical-details.xml b/documentation/ref-manual/technical-details.xml
index e5c8eb83b6..558af87d91 100644
--- a/documentation/ref-manual/technical-details.xml
+++ b/documentation/ref-manual/technical-details.xml
@@ -1022,15 +1022,17 @@
the package that depends on the shared library to the package
that contains the library.</para>
- <para>If the library being linked against is versioned
- (i.e. includes a version number), then the automatically added
- runtime dependency will specify at least that version, as if
+ <para>The automatically added runtime dependency also includes
+ a version restriction.
+ This version restriction specifies that at least the current
+ version of the package that provides the shared library must be
+ used, as if
"<replaceable>package</replaceable> (>= <replaceable>version</replaceable>)"
had been added to
<link linkend='var-RDEPENDS'><filename>RDEPENDS</filename></link>.
- This dependency forces an upgrade of the package that provides
- the shared library when installing the package that depends on
- the library, if needed.</para>
+ This forces an upgrade of the package containing the shared
+ library when installing the package that depends on the
+ library, if needed.</para>
<para>If you want to avoid a package being registered as
providing a particular shared library (e.g. because the library
@@ -1054,8 +1056,8 @@
task.</para>
<para>Simultaneously, all pkg-config modules installed by the
- recipe are inspected to see what other modules on which the
- pkg-config modules depend.
+ recipe are inspected to see what other pkg-config modules they
+ depend on.
A module is seen as depending on another module if it contains
a "Requires:" line that specifies the other module.
For each module dependency,
@@ -1078,7 +1080,7 @@
task of each recipe in
<link linkend='var-DEPENDS'><filename>DEPENDS</filename></link>
through use of a
- <ulink url='&YOCTO_DOCS_BB_URL;#variable-flags'><filename>[vardeps]</filename></ulink>
+ <filename>[</filename><ulink url='&YOCTO_DOCS_BB_URL;#variable-flags'><filename>deptask</filename></ulink><filename>]</filename>
declaration, which guarantees that the required
shared-library/module-to-package mapping information will be available
when needed as long as <filename>DEPENDS</filename> has been