aboutsummaryrefslogtreecommitdiffstats
path: root/documentation
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2013-05-13 15:07:05 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-22 17:23:41 +0100
commit68deb6c14f4f0fb04020a773bca2e88f4dcf0c2d (patch)
treeccb439eb11fdf1120568b49192dd782ca086402c /documentation
parentb47c993ca0f585dd677427bee6e6274b2b41b6e3 (diff)
downloadopenembedded-core-contrib-68deb6c14f4f0fb04020a773bca2e88f4dcf0c2d.tar.gz
kernel-dev: Updates to "Creating the Append File" section.
Pointed out by Robert P. J. Day that I was using the wrong FILESEXTRAPATHS example for an append file. I failed to include the "_prepend" part of the variable. Also, the wording based on the example made some assumptions and was not entirely accurate. The changes I put in made the section very specific. Reported-by: Robert P. J. Day <rpjday@crashcourse.ca> (From yocto-docs rev: 659c5a9c41a92f469ea0ea3630e11b4ba2df8f56) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation')
-rw-r--r--documentation/kernel-dev/kernel-dev-common.xml15
1 files changed, 11 insertions, 4 deletions
diff --git a/documentation/kernel-dev/kernel-dev-common.xml b/documentation/kernel-dev/kernel-dev-common.xml
index 6f39a70dff..e18eb31923 100644
--- a/documentation/kernel-dev/kernel-dev-common.xml
+++ b/documentation/kernel-dev/kernel-dev-common.xml
@@ -88,14 +88,21 @@
<literallayout class='monospaced'>
&lt;your-layer&gt;/recipes-kernel/linux/linux-yocto_3.4.bbappend
</literallayout>
- The append file should initially contain the following text:
+ The append file should initially extend the
+ <ulink url='&YOCTO_DOCS_REF_URL;#var-FILESPATH'><filename>FILESPATH</filename></ulink>
+ search path by prepending the directory that contains your
+ files to the
+ <ulink url='&YOCTO_DOCS_REF_URL;#var-FILESEXTRAPATHS'><filename>FILESEXTRAPATHS</filename></ulink>
+ variable as follows:
<literallayout class='monospaced'>
- <ulink url='&YOCTO_DOCS_REF_URL;#var-FILESEXTRAPATHS'>FILESEXTRAPATHS</ulink> := "${THISDIR}/${PN}"
+ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
</literallayout>
The path <filename>${THISDIR}/${</filename><ulink url='&YOCTO_DOCS_REF_URL;#var-PN'><filename>PN</filename></ulink><filename>}</filename> expands
to "linux-yocto" in the current directory for this example.
- If you add any new files that modify the kernel recipe,
- you need to place them in your layer in the following area:
+ If you add any new files that modify the kernel recipe and you
+ have extended <filename>FILESPATH</filename> as
+ described above, you must place the files in your layer in the
+ following area:
<literallayout class='monospaced'>
&lt;your-layer&gt;/recipes-kernel/linux/linux-yocto/
</literallayout>