summaryrefslogtreecommitdiffstats
path: root/documentation/ref-manual
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2018-12-13 16:16:45 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-15 11:48:59 +0000
commit1e534573c73104819f455b6816b5271a24bee09a (patch)
treeef3241e7e12a83021dfc8b448df077161422ca53 /documentation/ref-manual
parent989577c4ad53d7fc40a73f999a09a08fceb318a4 (diff)
downloadopenembedded-core-contrib-1e534573c73104819f455b6816b5271a24bee09a.tar.gz
ref-manual: Document the fifth argument to PACKAGECONFIG
(From yocto-docs rev: adb17e3172c829de77d2664c91f7cf4b22c9e5f0) Signed-off-by: Scott Rifenbark <srifenbark@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/ref-manual')
-rw-r--r--documentation/ref-manual/ref-variables.xml12
1 files changed, 8 insertions, 4 deletions
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index c3cc1fab57..9e51b7591c 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -10337,9 +10337,9 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
Here is the basic block structure:
<literallayout class='monospaced'>
PACKAGECONFIG ??= "f1 f2 f3 ..."
- PACKAGECONFIG[f1] = "--with-f1,--without-f1,build-deps-f1,rt-deps-f1"
- PACKAGECONFIG[f2] = "--with-f2,--without-f2,build-deps-f2,rt-deps-f2"
- PACKAGECONFIG[f3] = "--with-f3,--without-f3,build-deps-f3,rt-deps-f3"
+ PACKAGECONFIG[f1] = "--with-f1,--without-f1,build-deps-f1,rt-deps-f1,rt-recs-f1"
+ PACKAGECONFIG[f2] = "--with-f2,--without-f2,build-deps-f2,rt-deps-f2,rt-recs-f2"
+ PACKAGECONFIG[f3] = "--with-f3,--without-f3,build-deps-f3,rt-deps-f3,rt-recs-f3"
</literallayout>
</para>
@@ -10348,7 +10348,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
variable itself specifies a space-separated list of the
features to enable.
Following the features, you can determine the behavior of
- each feature by providing up to four order-dependent
+ each feature by providing up to five order-dependent
arguments, which are separated by commas.
You can omit any argument you like but must retain the
separating commas.
@@ -10374,6 +10374,10 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
(<link linkend='var-RDEPENDS'><filename>RDEPENDS</filename></link>)
that should be added if the feature is enabled.
</para></listitem>
+ <listitem><para>Additional runtime recommendations
+ (<link linkend='var-RRECOMMENDS'><filename>RRECOMMENDS</filename></link>)
+ that should be added if the feature is enabled.
+ </para></listitem>
</orderedlist>
</para>