aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/dev-manual
diff options
context:
space:
mode:
authorRobert P. J. Day <crashcourse.ca>2013-11-22 10:21:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-03 12:53:19 +0000
commit47e7abc5190ccbcef1ae6c7cb46f563d30b32f32 (patch)
tree197c4b80020019c943a5f49dccced8f72afef2ad /documentation/dev-manual
parent4f7c36639c699508d792aa52820f1a84980597df (diff)
downloadopenembedded-core-contrib-47e7abc5190ccbcef1ae6c7cb46f563d30b32f32.tar.gz
dev-manual: Number of minor tweaks to Dev Manual, Chapter 5.
(From yocto-docs rev: 1027c4aefa0ba9f341c56eda7ee672d26c5e6813) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/dev-manual')
-rw-r--r--documentation/dev-manual/dev-manual-common-tasks.xml16
1 files changed, 8 insertions, 8 deletions
diff --git a/documentation/dev-manual/dev-manual-common-tasks.xml b/documentation/dev-manual/dev-manual-common-tasks.xml
index 1c5c17be07..ea1f0e5ec2 100644
--- a/documentation/dev-manual/dev-manual-common-tasks.xml
+++ b/documentation/dev-manual/dev-manual-common-tasks.xml
@@ -9,7 +9,7 @@
This chapter describes fundamental procedures such as creating layers,
adding new software packages, extending or customizing images,
porting work to new hardware (adding a new machine), and so forth.
- You will find the procedures documented here occur often in the
+ You will find that the procedures documented here occur often in the
development cycle using the Yocto Project.
</para>
@@ -23,7 +23,7 @@
each other.
You might find it tempting to keep everything in one layer when
working on a single project.
- However, the more modular you organize your Metadata, the easier
+ However, the more modular your Metadata, the easier
it is to cope with future changes.
</para>
@@ -77,7 +77,7 @@
</para>
<para>
- Furthermore, if you set up a local copy of the
+ As another example, if you set up a local copy of the
<filename>meta-intel</filename> Git repository
and then explore the folder of that general layer,
you will discover many Intel-specific BSP layers inside.
@@ -224,7 +224,7 @@
file within the layer.
If the layer adds distro policy, add the distro
configuration in a <filename>conf/distro/</filename>
- file with the layer.
+ file within the layer.
If the layer introduces new recipes, put the recipes
you need in <filename>recipes-*</filename>
subdirectories within the layer.
@@ -810,7 +810,7 @@
<filename>&lt;layer&gt;.conf</filename>).
</para></listitem>
<listitem><para><emphasis>The
- <filename>COPYING.MIT</filename>:</emphasis>
+ <filename>COPYING.MIT</filename> file:</emphasis>
The copyright and use notice for the software.
</para></listitem>
<listitem><para><emphasis>The <filename>README</filename>
@@ -826,7 +826,7 @@
in <filename>&lt;layer&gt;/recipes-example/example/</filename>.
The script creates a <filename>.bb</filename> file and a
directory, which contains a sample
- <filename>helloworld.c</filename> source file and along with
+ <filename>helloworld.c</filename> source file, along with
a sample patch file.
If you do not provide a recipe name, the script uses
"example".
@@ -1131,7 +1131,7 @@
<title>Writing a Recipe to Add a Package to Your Image</title>
<para>
- Recipes add packages to your image.
+ Recipes let you define packages you can add to your image.
Writing a recipe means creating a <filename>.bb</filename> file that sets some
variables.
For information on variables that are useful for recipes and for information about recipe naming
@@ -1546,7 +1546,7 @@
You need to create a <filename>configure</filename> task that configures the
unpacked kernel with a defconfig.
You can do this by using a <filename>make defconfig</filename> command or,
- more commonly, by copying in a suitable <filename>defconfig</filename> file and and then running
+ more commonly, by copying in a suitable <filename>defconfig</filename> file and then running
<filename>make oldconfig</filename>.
By making use of <filename>inherit kernel</filename> and potentially some of the
<filename>linux-*.inc</filename> files, most other functionality is