summaryrefslogtreecommitdiffstats
path: root/documentation/bsp-guide/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2010-11-04 13:01:19 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-04 20:54:30 +0000
commit890a794e38f2d11ec0dd6e39e5ab77a929cb51d9 (patch)
tree75a69ef3e6752085f5bc1a3d84fab378af5b515a /documentation/bsp-guide/Makefile
parent4b7f1eee28dafcb237f54e1739a9936fdd80ebc4 (diff)
downloadopenembedded-core-contrib-890a794e38f2d11ec0dd6e39e5ab77a929cb51d9.tar.gz
Created a new folder to hold the BSP Guide
I created a new sub folder to hold the BSP Guide by itself so there are three folders now for each of the Yocto manuals: BSP Guide, quick start and poky ref manual. The new folder for the BSP guide is 'bsp-guide'. It contains the bsp.xml file, its own Makefile, a bsp-guide.xml file, and its own 'Figures' directory. The 'bsp-guide.xml' file that was in the poky reference folder was deleted. Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
Diffstat (limited to 'documentation/bsp-guide/Makefile')
-rw-r--r--documentation/bsp-guide/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/documentation/bsp-guide/Makefile b/documentation/bsp-guide/Makefile
new file mode 100644
index 0000000000..7e8d216904
--- /dev/null
+++ b/documentation/bsp-guide/Makefile
@@ -0,0 +1,35 @@
+all: html pdf tarball
+
+pdf:
+ ../tools/poky-docbook-to-pdf bsp-guide.xml ../template
+
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
+
+html:
+# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
+ xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
+
+tarball: html
+ tar -cvzf bsp-guide.tgz style.css bsp-guide.html figures/poky-ref-manual.png
+
+validate:
+ xmllint --postvalid --xinclude --noout bsp-guide.xml
+
+OUTPUTS = bsp-guide.pdf bsp-guide.html
+SOURCES = *.png *.xml *.css *.svg
+
+publish:
+ scp -r $(OUTPUTS) $(SOURCES) o-hand.com:/srv/www/pokylinux.org/doc/
+
+clean:
+ rm -f $(OUTPUTS)